summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmail
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-24 00:37:28 +0200
committerChris <xchrisx@uber.space>2020-04-24 00:37:28 +0200
commit55787e8078d5d241d95cf251fda8fff5b88164ae (patch)
tree23e3d4f7ea1daf613bd93012a1588921a4a0d617 /trinity-base/kmail
parent912f40ace9505c591e61e02a47e101c864c98bca (diff)
downloadtde-packaging-gentoo-55787e8078d5d241d95cf251fda8fff5b88164ae.tar.gz
tde-packaging-gentoo-55787e8078d5d241d95cf251fda8fff5b88164ae.zip
Live ebuilds: Add `KMail` and depending ebuilds.
- `libkpgp` - `libksieve` - `tdepim-tdeioslaves` Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/kmail')
-rw-r--r--trinity-base/kmail/kmail-9999.ebuild55
-rw-r--r--trinity-base/kmail/metadata.xml7
2 files changed, 62 insertions, 0 deletions
diff --git a/trinity-base/kmail/kmail-9999.ebuild b/trinity-base/kmail/kmail-9999.ebuild
new file mode 100644
index 00000000..47f83498
--- /dev/null
+++ b/trinity-base/kmail/kmail-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdepim"
+
+inherit trinity-meta-2
+
+DESCRIPTION="The email client for Trinity"
+
+IUSE="crypt imap mbox sasl"
+
+# The magic of KMail, is fully done by individual TDEIOSlaves,
+# so we trigger them to be build, depending on USE flags.
+
+COMMON_DEPEND="
+ =trinity-base/libtdepim-${PV}
+ =trinity-base/mimelib-${PV}
+ =trinity-base/libtdenetwork-${PV}
+ =trinity-base/ktnef-${PV}
+ =trinity-base/libkcal-${PV}
+ =trinity-base/libkmime-${PV}
+ =trinity-base/libkpgp-${PV}
+ =trinity-base/certmanager-${PV}
+ =trinity-base/libkpimidentities-${PV}
+ =trinity-base/libksieve-${PV}"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/pinentry )
+ =trinity-base/tdebase-tdeioslaves-${PV}
+ mbox? ( =trinity-base/tdepim-tdeioslaves-${PV} )
+ imap? ( =trinity-base/tdepim-tdeioslaves-${PV}[sasl=] )"
+
+TSM_EXTRACT_ALSO="
+ ktnef/
+ libemailfunctions/
+ mimelib/
+ libtdenetwork/
+ certmanager/lib/
+ libtdepim/
+ korganizer/korganizerinterface.h
+ korganizer/kcalendarinterface.h
+ libkpgp/
+ libkmime/
+ libksieve/
+ kmail/"
+
+pkg_postinst () {
+ if use crypt; then
+ elog "Remember that you can build Pinentry with TQt support."
+ elog "To do so, just emerge app-crypt/pinentry with \"tqt\" USE"
+ elog "and use \"eselect pinentry set pinentry-tqt\" to use it."
+ fi
+} \ No newline at end of file
diff --git a/trinity-base/kmail/metadata.xml b/trinity-base/kmail/metadata.xml
new file mode 100644
index 00000000..61b4108b
--- /dev/null
+++ b/trinity-base/kmail/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Chris</name>
+ </maintainer>
+</pkgmetadata>