summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmilo/kmilo-9999.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /trinity-base/kmilo/kmilo-9999.ebuild
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'trinity-base/kmilo/kmilo-9999.ebuild')
-rw-r--r--trinity-base/kmilo/kmilo-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/trinity-base/kmilo/kmilo-9999.ebuild b/trinity-base/kmilo/kmilo-9999.ebuild
new file mode 100644
index 00000000..5920cd6c
--- /dev/null
+++ b/trinity-base/kmilo/kmilo-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdeutils"
+
+inherit trinity-meta
+
+DESCRIPTION="kded module supports some hardware input devices, such as special keys"
+KEYWORDS=""
+IUSE="asus-laptop dell-laptop powerbook-laptop thinkpad-laptop vaio-laptop lm_sensors"
+
+DEPEND="powerbook-laptop? ( app-laptop/pbbuttonsd )"
+RDEPEND="${DEPEND}
+ lm_sensors? ( sys-apps/lm_sensors )"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with asus-laptop ASUS)
+ $(cmake-utils_use_with dell-laptop I8K)
+ $(cmake-utils_use_with powerbook-laptop POWERBOOK2)
+ $(cmake-utils_use_with thinkpad-laptop THINKPAD)
+ $(cmake-utils_use_with vaio-laptop VAIO)
+ $(cmake-utils_use_with lm_sensors SENSORS)
+ )
+
+ trinity-meta_src_configure
+}