summaryrefslogtreecommitdiffstats
path: root/trinity-base/korganizer
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-18 19:10:36 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 23:18:46 +0000
commitcc1ac24d4da2167f8d35239f7b9ecb3096adcba1 (patch)
treeae2ec4bbadf8bbabc55bb120e6f8b81f0a3a4c89 /trinity-base/korganizer
parent59a5a64b42421e246b5b90bf0d944299346faa7e (diff)
downloadtde-packaging-gentoo-cc1ac24d4da2167f8d35239f7b9ecb3096adcba1.tar.gz
tde-packaging-gentoo-cc1ac24d4da2167f8d35239f7b9ecb3096adcba1.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 7.
This time: filelight, kdcop, kdf, kmix, knutclient, konversation, ksensors, noatun-plugins, tdegames-doc, tdeinit, tdepowersave, tde-i18n, arts, libtdenetwork, atlantik, kasteroids, katomic, kbackgammon, kbattleship, kblackbox, kbounce, kenolaba, kfouleggs, kgoldrunner, kjumpingcube, klickety, klines, kmahjongg, kmines, knetwalk, kolf, konquest, kpat, kpoker, kreversi, ksame, kshisen, ksirtet, ksmiletris, ksnake, ksokoban, kspaceduel, ktron, ktuberling, libtdegames, lskat, twin4, akregator, kaddressbook, kgantt, kmobile, knode, knotes, kontact, korganizer, ktnef, libkcal, libkholidays, libkmime, libkpimexchange, libkpimidentities, libtdepim and mimelib Also: Move filelight to trinity-apps. Fix tdegames-meta to use trinity-base. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/korganizer')
-rw-r--r--trinity-base/korganizer/korganizer-9999.ebuild34
1 files changed, 18 insertions, 16 deletions
diff --git a/trinity-base/korganizer/korganizer-9999.ebuild b/trinity-base/korganizer/korganizer-9999.ebuild
index b9f24c9b..04736fdc 100644
--- a/trinity-base/korganizer/korganizer-9999.ebuild
+++ b/trinity-base/korganizer/korganizer-9999.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdepim"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="A Personal Organizer for Trinity"
-KEYWORDS=""
+
IUSE+=" exchange"
+
COMMON_DEPEND="
- >=trinity-base/kgantt-${PV}:${SLOT}
- >=trinity-base/libtdepim-${PV}:${SLOT}
- >=trinity-base/libtdenetwork-${PV}:${SLOT}
- >=trinity-base/libkcal-${PV}:${SLOT}
- >=trinity-base/ktnef-${PV}:${SLOT}
- >=trinity-base/libkmime-${PV}:${SLOT}
- >=trinity-base/libkholidays-${PV}:${SLOT}
- >=trinity-base/certmanager-${PV}:${SLOT}
- >=trinity-base/libkpimidentities-${PV}:${SLOT}
- >=trinity-base/kaddressbook-${PV}:${SLOT}
- exchange? ( >=trinity-base/libkpimexchange-${PV}:${SLOT} )"
+ =trinity-base/kgantt-${PV}
+ =trinity-base/libtdepim-${PV}
+ =trinity-base/libtdenetwork-${PV}
+ =trinity-base/libkcal-${PV}
+ =trinity-base/ktnef-${PV}
+ =trinity-base/libkmime-${PV}
+ =trinity-base/libkholidays-${PV}
+ =trinity-base/certmanager-${PV}
+ =trinity-base/libkpimidentities-${PV}
+ =trinity-base/kaddressbook-${PV}
+ exchange? ( =trinity-base/libkpimexchange-${PV} )"
# >=trinity-base/tdepim-tderesources-${PV}:${SLOT}
DEPEND+=" ${COMMON_DEPEND}"
@@ -40,7 +42,7 @@ TSM_EXTRACT_ALSO+=" libkpimexchange/core/" # required for USE=exchange
src_configure () {
mycmakeargs=(
- $(cmake-utils_use_with exchange EXCHANGE )
+ -DWITH_EXCHANGE="$(usex exchange)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}