summaryrefslogtreecommitdiffstats
path: root/trinity-base/lisa/lisa-14.0.8.ebuild
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-14 14:53:51 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-29 02:03:03 +0100
commitd44f6cfe2966c8793abbd23d415a74d061dbfc45 (patch)
tree295d2c1beb33777d4d3bc9e84d0091445d71240f /trinity-base/lisa/lisa-14.0.8.ebuild
parent67151d41efefb81a0ae15d576e49847205b63c83 (diff)
downloadtde-packaging-gentoo-d44f6cfe2966c8793abbd23d415a74d061dbfc45.tar.gz
tde-packaging-gentoo-d44f6cfe2966c8793abbd23d415a74d061dbfc45.zip
14.0.7 and 14.0.8 ebuilds for tdenetwork
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-base/lisa/lisa-14.0.8.ebuild')
-rw-r--r--trinity-base/lisa/lisa-14.0.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/trinity-base/lisa/lisa-14.0.8.ebuild b/trinity-base/lisa/lisa-14.0.8.ebuild
new file mode 100644
index 00000000..3260e157
--- /dev/null
+++ b/trinity-base/lisa/lisa-14.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdenetwork"
+TRINITY_SUBMODULE="lanbrowsing"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity Lan Information Server - allows to share information over a network."
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ trinity-meta-2_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/lisa" > "${T}/lisa"
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/reslisa" > "${T}/reslisa"
+ doinitd "${T}/lisa" "${T}/reslisa"
+
+ newconfd "${FILESDIR}/lisa.conf" lisa
+ newconfd "${FILESDIR}/reslisa.conf" reslisa
+
+ echo '# Default lisa configfile' > "$D/etc/lisarc"
+ echo '# Default reslisa configfile' > "$D/etc/reslisarc"
+}