summaryrefslogtreecommitdiffstats
path: root/trinity-base/lisa/lisa-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/lisa/lisa-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/lisa/lisa-14.1.0.ebuild')
-rw-r--r--trinity-base/lisa/lisa-14.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-base/lisa/lisa-14.1.0.ebuild b/trinity-base/lisa/lisa-14.1.0.ebuild
new file mode 100644
index 00000000..4b1846a0
--- /dev/null
+++ b/trinity-base/lisa/lisa-14.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+TRINITY_SUBMODULE="lanbrowsing"
+
+TRINITY_MODULE_NAME="tdenetwork"
+TRINITY_MODULE_TYPE="core"
+TRINITY_HANDBOOK="optional"
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity Lan Information Server - allows to share information over a network."
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_install() {
+ trinity-meta-2_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/lisa" > "${T}/lisa"
+ sed -e "s:_TDEDIR_:${TDEDIR}:g" "${FILESDIR}/reslisa" > "${T}/reslisa"
+ doinitd "${T}/lisa" "${T}/reslisa"
+
+ newconfd "${FILESDIR}/lisa.conf" lisa
+ newconfd "${FILESDIR}/reslisa.conf" reslisa
+
+ echo '# Default lisa configfile' > "$D/etc/lisarc"
+ echo '# Default reslisa configfile' > "$D/etc/reslisarc"
+}