summaryrefslogtreecommitdiffstats
path: root/trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild')
-rw-r--r--trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild b/trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild
new file mode 100644
index 00000000..23f50ba3
--- /dev/null
+++ b/trinity-base/tde-i18n/tde-i18n-14.0.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_LANGS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et
+ eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms
+ nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta te
+ tg th tr uk uz uz@cyrillic vi wa zh_CN zh_TW"
+
+TRINITY_MODULE_NAME="tde-i18n"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-base-2
+
+DESCRIPTION="Trinity internationalization package"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+SLOT="14"
+
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+run_phase() {
+ local lang dir phase;
+ phase=${1}
+ lang=${2}
+
+ dir="tde-i18n-${lang}"
+ pushd "${S}/${dir}" || die "No such dir: ${dir}"
+ CMAKE_USE_DIR="${S}/${dir}"
+ BUILD_DIR="${WORKDIR}/${dir}-build"
+ trinity-base-2_${phase}
+ popd || die
+}
+
+src_prepare() {
+ trinity_l10n_for_each_locale_do run_phase src_prepare
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_ALL=ON )
+ trinity_l10n_for_each_locale_do run_phase src_configure
+}
+
+src_compile() {
+ trinity_l10n_for_each_locale_do run_phase src_compile
+}
+
+src_install() {
+ trinity_l10n_for_each_locale_do run_phase src_install
+}