summaryrefslogtreecommitdiffstats
path: root/trinity-base/tde-i18n
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-03 14:12:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 01:49:57 +0100
commit1ebc9f7807db09eb53d7f304c4d4126700c6b297 (patch)
tree42fd1e502522a40d2c2f002399515048b235405c /trinity-base/tde-i18n
parent5732f27c0e26d2fba84055858043018f5b458718 (diff)
downloadtde-packaging-gentoo-1ebc9f7807db09eb53d7f304c4d4126700c6b297.tar.gz
tde-packaging-gentoo-1ebc9f7807db09eb53d7f304c4d4126700c6b297.zip
*/*: 9999: Sanitise eclass/ebuild vars, drop set-trinityver and need-trinity
Uniform ebuild variable blocks according to skel.ebuild and by devmanual example Sort some DEPENDs, fix some DESCRIPTIONs Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'trinity-base/tde-i18n')
-rw-r--r--trinity-base/tde-i18n/tde-i18n-9999.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/trinity-base/tde-i18n/tde-i18n-9999.ebuild b/trinity-base/tde-i18n/tde-i18n-9999.ebuild
index d6122aa0..dfcd88df 100644
--- a/trinity-base/tde-i18n/tde-i18n-9999.ebuild
+++ b/trinity-base/tde-i18n/tde-i18n-9999.ebuild
@@ -3,24 +3,20 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tde-i18n"
-inherit trinity-base-2
+TRINITY_LANGS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et
+ eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms
+ nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta te
+ tg th tr uk uz uz@cyrillic vi wa zh_CN zh_TW"
-set-trinityver
+TRINITY_MODULE_NAME="tde-i18n"
+inherit trinity-base-2
DESCRIPTION="Trinity internationalization package"
HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="|| ( GPL-2 GPL-3 )"
-
-SLOT="${TRINITY_VER}"
-need-trinity
-
-TRINITY_LANGS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et
- eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms
- nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta te
- tg th tr uk uz uz@cyrillic vi wa zh_CN zh_TW"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
for X in ${TRINITY_LANGS} ; do
IUSE="${IUSE} l10n_${X}"
@@ -36,7 +32,7 @@ run_phase() {
CMAKE_USE_DIR="${S}/${dir}"
BUILD_DIR="${WORKDIR}/${dir}-build"
trinity-base-2_${phase}
- popd
+ popd || die
}
src_prepare() {
@@ -45,7 +41,7 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=( -DBUILD_ALL=ON )
+ local mycmakeargs=( -DBUILD_ALL=ON )
trinity_l10n_for_each_locale_do run_phase src_configure
}