summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdegames-doc
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-06-13 17:05:08 -0400
committerSlávek Banko <slavek.banko@axis.cz>2020-11-27 10:18:47 +0100
commit9918cbb64bf1b7db67414deafbb6b4af9dc98473 (patch)
treef4e657e24f92bdd8277416fb3f2bc61ea2d68075 /trinity-base/tdegames-doc
parent7ed6b42adb46d6e23c9e523d49d4ed0b4bc04aaf (diff)
downloadtde-packaging-gentoo-9918cbb64bf1b7db67414deafbb6b4af9dc98473.tar.gz
tde-packaging-gentoo-9918cbb64bf1b7db67414deafbb6b4af9dc98473.zip
14.0.7 and 14.0.8 ebuilds for tdegames
Diffstat (limited to 'trinity-base/tdegames-doc')
-rw-r--r--trinity-base/tdegames-doc/Manifest2
-rw-r--r--trinity-base/tdegames-doc/tdegames-doc-14.0.7.ebuild27
-rw-r--r--trinity-base/tdegames-doc/tdegames-doc-14.0.8.ebuild27
3 files changed, 56 insertions, 0 deletions
diff --git a/trinity-base/tdegames-doc/Manifest b/trinity-base/tdegames-doc/Manifest
new file mode 100644
index 00000000..560e536a
--- /dev/null
+++ b/trinity-base/tdegames-doc/Manifest
@@ -0,0 +1,2 @@
+DIST tdegames-trinity-14.0.7.tar.xz 8636572 BLAKE2B 663371436a51b8595c63e40e33cb3dd685325cb3262fc2dbfa4353691c2a5616b28f1c2cc50200601242ff7da7662bcfd91ae4c6fadcd99b7bbe1ffbf042b323 SHA512 a4d723bab38f979914e4ff80fdd8ddc0adc077519364739e44b605982af112a447768fa4bb1c73a1755005b25c63e7d96262684c683aba477cbd11e74133ac37
+DIST tdegames-trinity-14.0.8.tar.xz 8638456 BLAKE2B 780d7df31e3b88913482b81297737354fba742aabaf5a42741cccd141acc21b60df35d0a8682e1d91fb0ea220c5e8735ad93ebeae85d6d712af1ac6d05c5399b SHA512 3c85cc18391df223020a63f9d4bc05d7e65f1e2f39c0397565b85603a4072f8725da8bfe42c88c311bc4cc7ad79316942a71221c774dae5ceb62ec60473dcfb1
diff --git a/trinity-base/tdegames-doc/tdegames-doc-14.0.7.ebuild b/trinity-base/tdegames-doc/tdegames-doc-14.0.7.ebuild
new file mode 100644
index 00000000..899551dc
--- /dev/null
+++ b/trinity-base/tdegames-doc/tdegames-doc-14.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdegames"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdegames-derived packages"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ~trinity-base/khelpcenter-${PV}"
+
+pkg_setup() {
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
+ fi
+
+ trinity-meta-2_pkg_setup
+}
diff --git a/trinity-base/tdegames-doc/tdegames-doc-14.0.8.ebuild b/trinity-base/tdegames-doc/tdegames-doc-14.0.8.ebuild
new file mode 100644
index 00000000..899551dc
--- /dev/null
+++ b/trinity-base/tdegames-doc/tdegames-doc-14.0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdegames"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdegames-derived packages"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ~trinity-base/khelpcenter-${PV}"
+
+pkg_setup() {
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
+ fi
+
+ trinity-meta-2_pkg_setup
+}