summaryrefslogtreecommitdiffstats
path: root/trinity-base/twin/twin-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-17 20:59:46 +0300
committerSlávek Banko <slavek.banko@axis.cz>2024-04-26 02:57:58 +0200
commitd6b1e54fc81daf6c61bd27221bf17cffd766ed4d (patch)
tree742360a065f0776f4bf6bd0eae51da15d0d975a2 /trinity-base/twin/twin-14.1.0.ebuild
parent9a76c13fddb55b0f202e048df62c939e06f39559 (diff)
downloadtde-packaging-gentoo-d6b1e54fc81daf6c61bd27221bf17cffd766ed4d.tar.gz
tde-packaging-gentoo-d6b1e54fc81daf6c61bd27221bf17cffd766ed4d.zip
Removing version TDE-14.1.0
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 4b3f0a054757e31efd942db76c6f28e4c26433dd)
Diffstat (limited to 'trinity-base/twin/twin-14.1.0.ebuild')
-rw-r--r--trinity-base/twin/twin-14.1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/trinity-base/twin/twin-14.1.0.ebuild b/trinity-base/twin/twin-14.1.0.ebuild
deleted file mode 100644
index eacf7d6c..00000000
--- a/trinity-base/twin/twin-14.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Copyright 2020-2023 The Trinity Desktop Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-TRINITY_MODULE_NAME="tdebase"
-TRINITY_MODULE_TYPE="core"
-inherit trinity-meta-2
-
-DESCRIPTION="Trinity window manager"
-if [[ ${PV} != *9999* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-IUSE="xcomposite xrandr xinerama +libconfig +pcre opengl"
-
-DEPEND="x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrender
- xcomposite? ( x11-libs/libXcomposite )
- xinerama? ( x11-base/xorg-proto )
- xrandr? ( x11-libs/libXrandr )
- libconfig? ( dev-libs/libconfig )
- opengl? ( virtual/opengl )
- pcre? ( dev-libs/libpcre[jit] )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_XCOMPOSITE="$(usex xcomposite)"
- -DWITH_XFIXES="$(usex xcomposite)"
- -DWITH_XRENDER="$(usex xcomposite)"
- -DWITH_OPENGL="$(usex opengl)"
- -DWITH_XRANDR="$(usex xrandr)"
- -DWITH_LIBCONFIG="$(usex libconfig)"
- -DWITH_PCRE="$(usex pcre)"
- -DWITH_XINERAMA="$(usex xinerama)"
- )
-
- trinity-meta-2_src_configure
-}
-
-pkg_postinst() {
- if ! use xcomposite; then
- for flag in xrandr xinerama libconfig pcre opengl; do
- use $flag && \
- ewarn "USE=\"$flag\" is passed, but it doesn't change anything due to" && \
- ewarn "$flag support in ${P} take effect only if composite is enabled."
- done
-
- fi
-}