summaryrefslogtreecommitdiffstats
path: root/x11-libs
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /x11-libs
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/tqscintilla/Manifest1
-rw-r--r--x11-libs/tqscintilla/tqscintilla-14.0.13.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/tqscintilla/Manifest b/x11-libs/tqscintilla/Manifest
index 3012ac36..36f73647 100644
--- a/x11-libs/tqscintilla/Manifest
+++ b/x11-libs/tqscintilla/Manifest
@@ -1 +1,2 @@
DIST tqscintilla-trinity-14.0.12.tar.xz 654360 BLAKE2B 96306124b2e64c524f1c484708aee367ab617c12ea8ff8b6c2fcd81823dd007be07f80478332a9dd06ecc473d7e61700d3c4996808d3a6cf968500e55f9df445 SHA512 58c702b025d10a1e04f51c0f78ef091dcd22f8ff905e842cc42be5af6bf2d7ac0cd878b26a4191d810735da16571aef2253977cf726f2707983ebae66ba9a98f
+DIST tqscintilla-trinity-14.0.13.tar.xz 654328 BLAKE2B 9e0ba9a459aeb17a35a8d237490a85ddd383b570427fddc66c2943649a064f564d1612c6b67abd41e99c2e2b293e77c18cc3d46a7fb6d07888cf078ae6353d55 SHA512 41bf8b6f3bb63b25100ce7cc8228dc4043e8a751fae33189ca4e9465ae09bd1020c6bd21e87e81330b986bef71ed188dd5b2c18f76e553035c4404632fe95ca5
diff --git a/x11-libs/tqscintilla/tqscintilla-14.0.13.ebuild b/x11-libs/tqscintilla/tqscintilla-14.0.13.ebuild
new file mode 100644
index 00000000..76c1ace2
--- /dev/null
+++ b/x11-libs/tqscintilla/tqscintilla-14.0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="tqscintilla"
+
+inherit trinity-base-2
+
+DESCRIPTION="TQt source code editing component based on Scintilla"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}${TQBASE}"
+ -DHTML_INSTALL_DIR="${TDEDIR}/share/doc/tde/HTML"
+ -DBUILD_ALL=ON
+ )
+ trinity-base-2_src_configure
+}