summaryrefslogtreecommitdiffstats
path: root/dev-libs/dbus-1-tqt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dbus-1-tqt')
-rw-r--r--dev-libs/dbus-1-tqt/Manifest1
-rw-r--r--dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/dbus-1-tqt/Manifest b/dev-libs/dbus-1-tqt/Manifest
index 2486fdac..263a7891 100644
--- a/dev-libs/dbus-1-tqt/Manifest
+++ b/dev-libs/dbus-1-tqt/Manifest
@@ -1 +1,2 @@
DIST dbus-1-tqt-trinity-14.1.1.tar.xz 90232 BLAKE2B 4faf9f8e6006fb5b35b4d8fcda12e3ce5c42f573398b5761557f7dfbb03b4f452500c5c9ce12c6f4d9e085773508eb859be9b172ffd6df9113a9d54e0b287ebb SHA512 cab1be01f30ac788372e4c42cebafbebaa2e7b410e7ca133875bc3aaa0779d432041ac4c0c65a5b2e6b384f42fb89bc7c93984d4c90a05c2110df3c4c1cf7a68
+DIST dbus-1-tqt-trinity-14.1.2.tar.xz 90256 BLAKE2B 1aee7f1e5f767250e0cafe43d3177f1cb04cdcaeb2f634f509f60c1dbbc9425c01016f898d927ae58a63b8ebb79c813d3e5ace361a1eaa18b3c5f239ca00e434 SHA512 212bcf647acde7717cc813e3d1c3e7d3985796fa4b7e425127d1b1d401a674d1d75148b625ba49e905de2f4b5c949948b49ae371ab2a540c5062355f6dcc457b
diff --git a/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild b/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild
new file mode 100644
index 00000000..1727a4fd
--- /dev/null
+++ b/dev-libs/dbus-1-tqt/dbus-1-tqt-14.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="dbus-1-tqt"
+inherit trinity-base-2
+
+DESCRIPTION="D-BUS TQt bindings"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="sys-apps/dbus
+ ~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake_src_configure
+}