summaryrefslogtreecommitdiffstats
path: root/dev-libs/libr
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libr')
-rw-r--r--dev-libs/libr/Manifest1
-rw-r--r--dev-libs/libr/libr-14.1.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libr/Manifest b/dev-libs/libr/Manifest
index 517e0751..90dbeda5 100644
--- a/dev-libs/libr/Manifest
+++ b/dev-libs/libr/Manifest
@@ -1 +1,2 @@
DIST libr-trinity-14.1.0.tar.xz 83092 BLAKE2B a7ecc1401bbacbb53794aa16d7aba1c731cf76f1988b036ff2ebae2d29fcce1b1abaf36d74e439e9518aa475888efcd409abecd06fe805e584649e3d3fc7922a SHA512 db55623c1da02d3dabb072e150a4b1299b8a82b1969296fe0bc8fbb9f18b199bb600ee2cfb087b661399bf6f2841ecd3e8b6c86003d67bd5bb7c918e1f55c3ba
+DIST libr-trinity-14.1.1.tar.xz 83108 BLAKE2B 8931995598c56834aefc100578ccb251467d51047e43e9a70109176209adf3847cbf0b6e10f35e7b032c2cf4205aa788e09cb09c39168d7aabbc8f97996ce034 SHA512 81e1c1a712b3600402955a5a9d0444b408da7a14c7482b04c1d7c6c8877b66b0bd7022e30ee921d6a1e641929688a0678d10131780eed3adef78549da2fed97e
diff --git a/dev-libs/libr/libr-14.1.1.ebuild b/dev-libs/libr/libr-14.1.1.ebuild
new file mode 100644
index 00000000..0acf0114
--- /dev/null
+++ b/dev-libs/libr/libr-14.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="libr"
+inherit trinity-base-2
+
+DESCRIPTION="ELF resource access and editing library"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="sys-libs/binutils-libs:="
+DEPEND="${RDEPEND}
+ app-doc/doxygen
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_BACKEND_LIBBFD=ON
+ -DWITH_BACKEND_LIBELF=OFF
+ -DWITH_BACKEND_READONLY=OFF
+ )
+ cmake_src_configure
+}