summaryrefslogtreecommitdiffstats
path: root/dev-qt/qt-meta/qt-meta-3.3.8d.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qt-meta/qt-meta-3.3.8d.ebuild')
-rw-r--r--dev-qt/qt-meta/qt-meta-3.3.8d.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-qt/qt-meta/qt-meta-3.3.8d.ebuild b/dev-qt/qt-meta/qt-meta-3.3.8d.ebuild
new file mode 100644
index 00000000..d64ac5d3
--- /dev/null
+++ b/dev-qt/qt-meta/qt-meta-3.3.8d.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=3
+
+DESCRIPTION="This is a meta package for a Qt3 toolkit it is needed to keep dependencies clean"
+HOMEPAGE="http://qt.nokia.com/ http://www.trinitydesktop.org/"
+
+LICENSE="|| ( QPL-1.0 GPL-2 GPL-3 )"
+SLOT="3"
+KEYWORDS="amd64 x86"
+IUSE="cups debug doc examples firebird ipv6 mysql nas nis opengl postgres sqlite xinerama"
+
+DEPEND="
+ =dev-qt/qt-${PV}:${SLOT}[cups=,debug=,doc=,examples=,firebird=,ipv6=,mysql=]
+ =dev-qt/qt-${PV}:${SLOT}[nas=,nis=,opengl=,postgres=,sqlite=,xinerama=]"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ echo
+ einfo "Please note that this meta package is only provided for capability."
+ einfo "No packages should depend directly on this meta package, but on the"
+ einfo "dev-qt/qt:${SLOT} package."
+ echo
+}