summaryrefslogtreecommitdiffstats
path: root/trinity-apps/gwenview-i18n
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/gwenview-i18n')
-rw-r--r--trinity-apps/gwenview-i18n/Manifest1
-rw-r--r--trinity-apps/gwenview-i18n/gwenview-i18n-14.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/gwenview-i18n/Manifest b/trinity-apps/gwenview-i18n/Manifest
index 63f52a96..0517c32c 100644
--- a/trinity-apps/gwenview-i18n/Manifest
+++ b/trinity-apps/gwenview-i18n/Manifest
@@ -1 +1,2 @@
DIST gwenview-i18n-trinity-14.1.0.tar.xz 1384996 BLAKE2B cfcec0e044b74180076c3a494bd07ce327da4a4a12b283e0fe0338ae571a043ea1b3628d6dbff2111b1e51dbcf7d2b14f9431c5163e4d5f91a94c3125127e496 SHA512 333b235089c24c71837a86a614817ac310c257ce82f8f98dd0acb95d365e3b10f5a6624ec617eae4eb0d8cd7bfba48e2472eb79bd28b9b3b0051fc3980b2c4a3
+DIST gwenview-i18n-trinity-14.1.1.tar.xz 1385004 BLAKE2B 11539aa7eec64a1ba7ca187ff370210f656418bf59764ff93af2ab0110983729b85b6351f00a85fb5cc9edced998480d4024bf19a555389ac0d3f8c3e9587723 SHA512 99d9a8eb928a4576684c8399ce2efbd98d1181228d1e255de4f222d18b432c676078e8ff5815edfd60a27f9b5b15600f238f9375e9214d8aac1b76624ee9b0f3
diff --git a/trinity-apps/gwenview-i18n/gwenview-i18n-14.1.1.ebuild b/trinity-apps/gwenview-i18n/gwenview-i18n-14.1.1.ebuild
new file mode 100644
index 00000000..be6b7456
--- /dev/null
+++ b/trinity-apps/gwenview-i18n/gwenview-i18n-14.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TEG_PO_DIR=${S}
+
+TRINITY_LANGS="ar br cy el et fo he is ka ms nl pl ro sk sv th ve zh_CN
+ az ca da en_GB fa fr hi it ko nb nso pt ru sr ta tr vi zh_TW
+ bg cs de es fi gl hu ja lt nds pa pt_BR rw sr@Latn uk xh zu"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_MODULE_TYPE="applications/graphics"
+inherit trinity-base-2
+
+DESCRIPTION="Internationalization support for Gwenview [Trinity]"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="FDL-1.2"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}