summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kaffeine
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kaffeine')
-rw-r--r--trinity-apps/kaffeine/Manifest2
-rw-r--r--trinity-apps/kaffeine/kaffeine-14.0.8.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/trinity-apps/kaffeine/Manifest b/trinity-apps/kaffeine/Manifest
new file mode 100644
index 00000000..38f52788
--- /dev/null
+++ b/trinity-apps/kaffeine/Manifest
@@ -0,0 +1,2 @@
+DIST kaffeine-trinity-14.0.7.tar.xz 2623204 BLAKE2B 518ca1867f49f597bd79d8d2353b02c803139038c4e26bf4e053d95d25f528c64e46d3c364ba44232b8df97a38f7024b0d60f24f33a12056d4573aaf28abe167 SHA512 329cb2b6fe7ad6e43b8db19a3fcbab794ce6d0e519052d905c8b9c5babf1006ce1d2de2703c7f30ebd2da945c2c723643c59934f259c4726dd5b05740f0054af
+DIST kaffeine-trinity-14.0.8.tar.xz 2604464 BLAKE2B 1024d3572a8b6504e3c9cfaf3faa24e9b340d321b1d8bbaf3715acef0f3ad04de8e4a629136f8242211b0e3745b5acdeac40e1b7b55595076d8d55cf827cbcdf SHA512 97ad2d91c68c94933b107a923d1dbae8df9d8de27a32c14098b6254d7e37dbd41c6d1b51f8e8489fc9ee22a88c7bb9e12448224d5d026b6ff1bff2ec3c3be11d
diff --git a/trinity-apps/kaffeine/kaffeine-14.0.8.ebuild b/trinity-apps/kaffeine/kaffeine-14.0.8.ebuild
new file mode 100644
index 00000000..caf42a30
--- /dev/null
+++ b/trinity-apps/kaffeine/kaffeine-14.0.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg bn br ca cs da de el es et fi fr ga gl he
+ hu it ja ka km lt mk nb nl nn pa pl pt pt_BR ru se sk sr
+ sr@Latn sv tg tr uk uz zh_CN zh_TW"
+
+inherit trinity-base-2
+
+DESCRIPTION="Media player for TDE using Xine and GStreamer backends."
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" dvb dpms gstreamer vorbis encode xcb xinerama"
+
+# As of April 2020 Kaffeine can be only build with xinerama support.
+# If that is fixed, the build option will be optional again.
+
+DEPEND+="
+ x11-base/xorg-proto
+ media-libs/xine-lib
+ dev-libs/libcdio
+ x11-libs/libXtst
+ gstreamer? (
+ media-libs/gstreamer
+ media-libs/gst-plugins-base[X]
+ )
+ encode? ( media-sound/lame )
+ vorbis? ( media-libs/libvorbis )
+ xcb? ( x11-libs/libxcb )
+ xinerama? ( x11-libs/libXinerama )
+ dvb? ( virtual/linuxtv-dvb-headers )"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XTEST=ON
+ -DWITH_DPMS="$(usex dpms)"
+ -DWITH_XINERAMA="$(usex xinerama)"
+ -DWITH_XCB="$(usex xcb)"
+ -DWITH_GSTREAMER="$(usex gstreamer)"
+ -DWITH_OGGVORBIS="$(usex vorbis)"
+ -DWITH_LAME="$(usex encode)"
+ -DWITH_DVB="$(usex dvb)"
+ )
+
+ trinity-base-2_src_configure
+}