summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kbarcode/kbarcode-14.0.8.ebuild')
-rw-r--r--trinity-apps/kbarcode/kbarcode-14.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild b/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild
new file mode 100644
index 00000000..e842c771
--- /dev/null
+++ b/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de el es fi fr hu it nl pl sv tr"
+
+inherit trinity-base-2
+
+DESCRIPTION="Barcode and label printing application for TDE"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+# Native GNU Barcode support seems to be broken right now.
+# The GNU Barcode binary is needed anyway.
+
+IUSE+=" javascript native_gnu_barcode"
+
+RDEPEND+=" app-text/barcode
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick )"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NATIVE_GNU_BARCODE="$(usex native_gnu_barcode)"
+ -DWITH_JAVASCRIPT="$(usex javascript)"
+ )
+
+ trinity-base-2_src_configure
+}