summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbiff
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kbiff')
-rw-r--r--trinity-apps/kbiff/Manifest1
-rw-r--r--trinity-apps/kbiff/kbiff-14.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/trinity-apps/kbiff/Manifest b/trinity-apps/kbiff/Manifest
index 46da7c7d..0edf67ad 100644
--- a/trinity-apps/kbiff/Manifest
+++ b/trinity-apps/kbiff/Manifest
@@ -1 +1,2 @@
DIST kbiff-trinity-14.1.1.tar.xz 139192 BLAKE2B 6f0479bcff71602483acd5ccae8228a5855afbe10f0788b515a263bc02e58b1c1ff7340c64e7efd3c2f1e84ea213a5ab470be7a2239fb900dcab3c04aa39f65b SHA512 0a061fb9cee970b8f612582d64401f5468cd1ed13c1383ced793692bd8f3a96d28b747bea105c7cb3ef425dad3fed4459adedc1106b3e324e8ca3b3418feee60
+DIST kbiff-trinity-14.1.2.tar.xz 139880 BLAKE2B 3d83bec57f32bd589f50d3fe6454a96f977b8c22725d5d5ce49067e8f47d6877aea914b71faf98958fd358aab4e3e7478d7a059fe742b7963954b2288a13bd68 SHA512 ecda6214a826bd42cceb578c1ceeba898f47eb1ddadcd5d9494830d94c522f252bb7181e0731674e4d140c52d9c0f1d2cd200575a9f858dedf30dea0db7364f9
diff --git a/trinity-apps/kbiff/kbiff-14.1.2.ebuild b/trinity-apps/kbiff/kbiff-14.1.2.ebuild
new file mode 100644
index 00000000..e10185c4
--- /dev/null
+++ b/trinity-apps/kbiff/kbiff-14.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="br cs da de el es et fi fr he hr hu is it ja
+ nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_TW"
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="Email notification utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="asus +ssl"
+
+# SSL support might need tdelibs build with +ssl USE.
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_SSL="$(usex ssl)"
+ -DWITH_MLED="$(usex asus)"
+ )
+
+ trinity-base-2_src_configure
+}