summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kiosktool
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kiosktool')
-rw-r--r--trinity-apps/kiosktool/Manifest1
-rw-r--r--trinity-apps/kiosktool/kiosktool-14.0.12.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/trinity-apps/kiosktool/Manifest b/trinity-apps/kiosktool/Manifest
index 2bd9dcff..fa98c6cd 100644
--- a/trinity-apps/kiosktool/Manifest
+++ b/trinity-apps/kiosktool/Manifest
@@ -1 +1,2 @@
DIST kiosktool-trinity-14.0.11.tar.xz 270100 BLAKE2B 6c7182b5f18e0bf33c4d9fa6a5ca8520eff0f889360829660e0836ef8336134d21cb64e58db8ae9c51107225c427b8b64f5a6f5ad2306034d0aeaacb4f6836fc SHA512 4ce9233359139a8c11d1391ab2db9741a54583db8257d48dc9abff938bd6719c964da5b9a73e58da239b6042c51a80977384292831b5f90ae29f4c2d2fe99d8d
+DIST kiosktool-trinity-14.0.12.tar.xz 270060 BLAKE2B 3434cb0fcf963a80c9aa3465f6181c3e362c0122ed579fbfc35282d27c728ee99af1f21a77f1048190b1932a1d114f83e9402ff33e29cbcbc10b4204f091297a SHA512 219ab86a2f0d71bc51c6f320928ec77a85a6af92294d2ee9aedb3845b2770b03f9b7643814c0c580cb32d201ba09a42ff0bef8cc5394bade50fe10615d21c209
diff --git a/trinity-apps/kiosktool/kiosktool-14.0.12.ebuild b/trinity-apps/kiosktool/kiosktool-14.0.12.ebuild
new file mode 100644
index 00000000..e9fc9574
--- /dev/null
+++ b/trinity-apps/kiosktool/kiosktool-14.0.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bg br ca cs cy da de en_GB es et fr ga is
+ it lt mt nl pt pt_BR ro ru sr sr@Latn sv ta tr"
+TRINITY_MODULE_TYPE="applications/settings"
+inherit trinity-base-2
+
+DESCRIPTION="Tool to configure the TDE kiosk framework "
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="kcmautostart"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KCM_AUTOSTART="$(usex kcmautostart)"
+ )
+
+ trinity-base-2_src_configure
+}