summaryrefslogtreecommitdiffstats
path: root/trinity-apps/knowit
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/knowit')
-rw-r--r--trinity-apps/knowit/Manifest1
-rw-r--r--trinity-apps/knowit/knowit-14.0.12.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/knowit/Manifest b/trinity-apps/knowit/Manifest
index b45acae2..4e68b82b 100644
--- a/trinity-apps/knowit/Manifest
+++ b/trinity-apps/knowit/Manifest
@@ -1 +1,2 @@
DIST knowit-trinity-14.0.11.tar.xz 97308 BLAKE2B 66dd15e1cefe2b0c0bea12a26c754dc0201d4f89c45755cff952e378be1c4e066ce77a3da58308330c7d8f4ab6d119b8bdc424ffe7935170e2e3d0aca7680fce SHA512 355ee85d8ad0110ae56245be283669d33a379bf51a3bd0803bdb5440b7f6d07507e4df3ca221637c2eb90fdefe78886ef0f298887db8fc6da76e121abd9c2e97
+DIST knowit-trinity-14.0.12.tar.xz 97272 BLAKE2B e0787b5bf2e9b8f4db96e74236f266b2a476c4b090c81db886c1f97be7fda879207d951590fb68a3aedabb3b247fbe65632f5a3e303b03991db02231f97c99b9 SHA512 c951c82960352ec54d2ae26ad2128aa43e2d5b4d126ec2f2c16a1c3b124a422f72febd87d776e6ecacd553344304f828b8b05fcd1bb6f35788b50ae6d1558a96
diff --git a/trinity-apps/knowit/knowit-14.0.12.ebuild b/trinity-apps/knowit/knowit-14.0.12.ebuild
new file mode 100644
index 00000000..1c20b42c
--- /dev/null
+++ b/trinity-apps/knowit/knowit-14.0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es fr hu nl pl ru sk zh_CN"
+TRINITY_MODULE_TYPE="applications/office"
+inherit trinity-base-2
+
+DESCRIPTION="Tool for managing notes"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}