summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-i18n
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/koffice-i18n')
-rw-r--r--trinity-apps/koffice-i18n/Manifest1
-rw-r--r--trinity-apps/koffice-i18n/koffice-i18n-14.1.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/trinity-apps/koffice-i18n/Manifest b/trinity-apps/koffice-i18n/Manifest
index cc7955eb..15527e4d 100644
--- a/trinity-apps/koffice-i18n/Manifest
+++ b/trinity-apps/koffice-i18n/Manifest
@@ -1 +1,2 @@
DIST koffice-i18n-trinity-14.1.0.tar.xz 43810080 BLAKE2B 8cfb87f10f822f10cd655c936d8de02296fc771a779d18bd112123ae355bd01f20807480ca08ef895014f18e1770d98e6a5dde9cabd02c9e59c9e059427a5400 SHA512 704814bf28182feebcbcdf8ad3ce5237df616d186566e23383efceb78858aa94f7f24b42aa656751078446b3097c43541fe56640c5289afe77148b0253ba6680
+DIST koffice-i18n-trinity-14.1.1.tar.xz 43809980 BLAKE2B 3bc35488b7872de9413bbdad7ab515248e2097b57c1ffd00d9cc7e1e0b91c1a47fc0c48a6d92af9d2845d1c54473525755cb01b334862122cd5285ec9dd5e89d SHA512 6568b9bf3cde7f475a7758a91a0055effd02321163284515a5ddd1ae66779020bc79b949fc6942cc6bb8dcf79cd800123981bc49dda72a833328c9f8c35cc33b
diff --git a/trinity-apps/koffice-i18n/koffice-i18n-14.1.1.ebuild b/trinity-apps/koffice-i18n/koffice-i18n-14.1.1.ebuild
new file mode 100644
index 00000000..32a3d59b
--- /dev/null
+++ b/trinity-apps/koffice-i18n/koffice-i18n-14.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2021-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/office"
+
+inherit trinity-base-2
+
+DESCRIPTION="TDE internationalization package for Koffice [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+TRINITY_LANGS="bg ca cs cy da de el en_GB es et eu fa fi
+ fr ga gl hu it ja km lv ms nb nds ne nl pl pt pt_BR
+ ru sk sl sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+RDEPEND="${DEPEND}"
+
+LINGUAS="en"
+
+find_lang() {
+ local lang
+ lang=${1}
+ LINGUAS+=" ${lang}"
+}
+
+src_prepare() {
+ trinity_l10n_for_each_locale_do find_lang
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_ALL=ON )
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ [[ "${LINGUAS}" == "en" ]] && return 0
+ trinity-base-2_src_install
+}