summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-i18n
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/koffice-i18n')
-rw-r--r--trinity-apps/koffice-i18n/Manifest1
-rw-r--r--trinity-apps/koffice-i18n/koffice-i18n-14.1.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/trinity-apps/koffice-i18n/Manifest b/trinity-apps/koffice-i18n/Manifest
index 0a4f9921..4f43c20c 100644
--- a/trinity-apps/koffice-i18n/Manifest
+++ b/trinity-apps/koffice-i18n/Manifest
@@ -1 +1,2 @@
DIST koffice-i18n-trinity-14.0.13.tar.xz 44081236 BLAKE2B b44d7f9263097ed251efd1eddd5a4b2ed7f1176725d0e36c2a574adb9db4d349ed7d33069aabc44737accd847443b692355c12edac6bf3835d7fcaa9dbf3c6a0 SHA512 c5272ddbddd36890bd50d12ddb0a28b766fd731fd13549f4fd7d3d215f806b004d86ef55df390f7cf4a698fa8a9251dfe949c908abffc572b0596d3aad3f9553
+DIST koffice-i18n-trinity-14.1.0.tar.xz 43810080 BLAKE2B 8cfb87f10f822f10cd655c936d8de02296fc771a779d18bd112123ae355bd01f20807480ca08ef895014f18e1770d98e6a5dde9cabd02c9e59c9e059427a5400 SHA512 704814bf28182feebcbcdf8ad3ce5237df616d186566e23383efceb78858aa94f7f24b42aa656751078446b3097c43541fe56640c5289afe77148b0253ba6680
diff --git a/trinity-apps/koffice-i18n/koffice-i18n-14.1.0.ebuild b/trinity-apps/koffice-i18n/koffice-i18n-14.1.0.ebuild
new file mode 100644
index 00000000..32a3d59b
--- /dev/null
+++ b/trinity-apps/koffice-i18n/koffice-i18n-14.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2021-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/office"
+
+inherit trinity-base-2
+
+DESCRIPTION="TDE internationalization package for Koffice [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+TRINITY_LANGS="bg ca cs cy da de el en_GB es et eu fa fi
+ fr ga gl hu it ja km lv ms nb nds ne nl pl pt pt_BR
+ ru sk sl sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+RDEPEND="${DEPEND}"
+
+LINGUAS="en"
+
+find_lang() {
+ local lang
+ lang=${1}
+ LINGUAS+=" ${lang}"
+}
+
+src_prepare() {
+ trinity_l10n_for_each_locale_do find_lang
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_ALL=ON )
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ [[ "${LINGUAS}" == "en" ]] && return 0
+ trinity-base-2_src_install
+}