summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kompose
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kompose')
-rw-r--r--trinity-apps/kompose/Manifest1
-rw-r--r--trinity-apps/kompose/kompose-14.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/trinity-apps/kompose/Manifest b/trinity-apps/kompose/Manifest
index 0d9ee37b..a24e58b7 100644
--- a/trinity-apps/kompose/Manifest
+++ b/trinity-apps/kompose/Manifest
@@ -1 +1,2 @@
DIST kompose-trinity-14.1.1.tar.xz 76384 BLAKE2B 782d709fab1cac52c6c087c0b95f9f224b40e1b8663daecc36d8198cf17926c51ff57584c69078b887973bc8a4e818a80afb92be4edd8d7b5d1cee6a0357886c SHA512 daef4f3cec7ae31d2fd62708ae54f2e6c2b7602a6bc75b64e005d80ba1bd059ef7175e3bf9701d94f195bbe3e7a1fae6ca0443576e72260f3a3e2e66596c3b7a
+DIST kompose-trinity-14.1.2.tar.xz 76524 BLAKE2B 2f4613672133f84a3d20d220e318b999463d3f7b4a67222d04bc74cafccf743f479ebe2d2be49c3f88a25756fe72af95e15666e6ddc12d49192a74a04ff6f230 SHA512 34fa1973f27762dc11bfb4d8bf24c22f5be5c425b6364b05ce00fc1a100bef2aee21f972c230963f07d892f663e443d93c9681d235ce53181d1657894ff39253
diff --git a/trinity-apps/kompose/kompose-14.1.2.ebuild b/trinity-apps/kompose/kompose-14.1.2.ebuild
new file mode 100644
index 00000000..cd2e04dc
--- /dev/null
+++ b/trinity-apps/kompose/kompose-14.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}