summaryrefslogtreecommitdiffstats
path: root/trinity-apps/krename
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/krename')
-rw-r--r--trinity-apps/krename/Manifest1
-rw-r--r--trinity-apps/krename/krename-14.0.12.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/krename/Manifest b/trinity-apps/krename/Manifest
index 199b0e87..e87b2dfe 100644
--- a/trinity-apps/krename/Manifest
+++ b/trinity-apps/krename/Manifest
@@ -1 +1,2 @@
DIST krename-trinity-14.0.11.tar.xz 187792 BLAKE2B 014ba7cabe8a3c1f5a729a28daa9c96a58c1545b0f8fc4e45cc48538f1ce22028f68d290b4ed5c9351a002a64a08aeb753cec97deb0402d103a985071a7c71d8 SHA512 e344685f3849b65c453dbc9c7e681f00b7a09a70e06706624e180cf9c7e0a04df228aafadd26d33bf9cef21b4851b66b699a24275fc3b8db7d6a15d685817f0a
+DIST krename-trinity-14.0.12.tar.xz 188060 BLAKE2B 5c643a99feae665ff5342a68d507095c08d74aab3535b4e4fc2607a1a3e4a5ed747e399278dce9c940d75080df8e602499caad75516fba83f588cec0f81774ed SHA512 eea5a3c18770c6f3167df40f6b04da595739e83b23850da8f278e8da355cd63f4f3d71166fe6947d78372fb3ff6b147598026b2fada7c2faba5172f3199638b5
diff --git a/trinity-apps/krename/krename-14.0.12.ebuild b/trinity-apps/krename/krename-14.0.12.ebuild
new file mode 100644
index 00000000..8b592294
--- /dev/null
+++ b/trinity-apps/krename/krename-14.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bs de es fr hu it ja nl
+ pl pt_BR ru sl sv tr zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="A powerful batch file renamer for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst () {
+ echo
+ einfo "Please note that KRename can use TDE's file information plugins as they're"
+ einfo "available, so you might want to install one or more of the following ebuilds:"
+ echo
+ einfo "tdeaddons-tdefile-plugins, tdeadmin-tdefile-plugins,"
+ einfo "tdegraphics-tdefile-plugins, tdemultimedia-tdefile-plugins,"
+ einfo "tdenetwork-tdefile-plugins, tdesdk-tdefile-plugins."
+ echo
+}