summaryrefslogtreecommitdiffstats
path: root/trinity-apps/krename
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/krename')
-rw-r--r--trinity-apps/krename/Manifest1
-rw-r--r--trinity-apps/krename/krename-14.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/krename/Manifest b/trinity-apps/krename/Manifest
index eabca2a7..ec327801 100644
--- a/trinity-apps/krename/Manifest
+++ b/trinity-apps/krename/Manifest
@@ -1 +1,2 @@
DIST krename-trinity-14.0.13.tar.xz 188052 BLAKE2B 3b008dad4c0fe8a43f059bb01a79564c6e956c1dad6677c7f05499fcb85f472101014ab5b5679fdeaa4231bdf008d2d8ead04f8981c856ee3d5444f8167c677c SHA512 e21a86fd0e010bd0ab7b64df682646d761dfb7c017f97d56283d8aca6ccf61a840f55a6b7703133e056aec7620c2d9e9097d3b832558a0026e47a9009a78406a
+DIST krename-trinity-14.1.0.tar.xz 188088 BLAKE2B f262ce621323109155aae9518ad69f10a853401c7d127eefd80bcf434bf1e58b5b3901ba44dad1539e3029a5e526b1879ce7bccd6529586abcfd45191014bda6 SHA512 168931d7ca2a5ffe0418e7f7a3f7db383d46ed84741e35d4c5179a9acda9c6f1b9c8cd369bc514bddca124b1c0a3c5b17a26f37253e8fe5b28d646929df8ceb7
diff --git a/trinity-apps/krename/krename-14.1.0.ebuild b/trinity-apps/krename/krename-14.1.0.ebuild
new file mode 100644
index 00000000..bd9ade38
--- /dev/null
+++ b/trinity-apps/krename/krename-14.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bs de es fr hu it ja nl
+ pl pt_BR ru sl sv tr zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="A powerful batch file renamer for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst () {
+ echo
+ einfo "Please note that KRename can use TDE's file information plugins as they're"
+ einfo "available, so you might want to install one or more of the following ebuilds:"
+ echo
+ einfo "tdeaddons-tdefile-plugins, tdeadmin-tdefile-plugins,"
+ einfo "tdegraphics-tdefile-plugins, tdemultimedia-tdefile-plugins,"
+ einfo "tdenetwork-tdefile-plugins, tdesdk-tdefile-plugins."
+ echo
+}