summaryrefslogtreecommitdiffstats
path: root/trinity-apps/krename
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/krename')
-rw-r--r--trinity-apps/krename/Manifest1
-rw-r--r--trinity-apps/krename/krename-14.1.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/krename/Manifest b/trinity-apps/krename/Manifest
index 976f8858..db39c7ce 100644
--- a/trinity-apps/krename/Manifest
+++ b/trinity-apps/krename/Manifest
@@ -1 +1,2 @@
DIST krename-trinity-14.1.1.tar.xz 188140 BLAKE2B 8b825abe1e7dd1ec4efa991e4dbc95bbe3dcbc36df28a17a264f8e8d8791072f3826e112d979d5aef2c374a5c10e0ba0e48a96603940239251eef1db1d66516a SHA512 ce0f09cbc86b5bd00ebadb987e9a708b899d7115f3f3ee16f82948355afe1f14023463245407f3924c5e4da3f0d8b5f21bc7fce6ed801c26da26015eb21b33ce
+DIST krename-trinity-14.1.2.tar.xz 184864 BLAKE2B d53857f3eff3b510d601c9eb06eada93debc96656ce2c6e07bcf96ab2de5b82193d83f33bae495614102d5a2ee9efa31b0368d8cf3f3af282807945bbd415d04 SHA512 9797fc1b3bbfb57d216f45f48df54b79afde3db555cc012b18294ea8e99cdd97a2ad6446da99f68789192e910160da2c9e72c029ea0b3b2159d2d4b4403c94be
diff --git a/trinity-apps/krename/krename-14.1.2.ebuild b/trinity-apps/krename/krename-14.1.2.ebuild
new file mode 100644
index 00000000..022cdc4a
--- /dev/null
+++ b/trinity-apps/krename/krename-14.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bs de es fr hu it ja nl
+ pl pt_BR ru sl sv tr zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="A powerful batch file renamer for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst () {
+ echo
+ einfo "Please note that KRename can use TDE's file information plugins as they're"
+ einfo "available, so you might want to install one or more of the following ebuilds:"
+ echo
+ einfo "tdeaddons-tdefile-plugins, tdeadmin-tdefile-plugins,"
+ einfo "tdegraphics-tdefile-plugins, tdemultimedia-tdefile-plugins,"
+ einfo "tdenetwork-tdefile-plugins, tdesdk-tdefile-plugins."
+ echo
+}