summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kscope
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kscope')
-rw-r--r--trinity-apps/kscope/Manifest1
-rw-r--r--trinity-apps/kscope/kscope-14.1.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/kscope/Manifest b/trinity-apps/kscope/Manifest
index 1d850281..b4ddd794 100644
--- a/trinity-apps/kscope/Manifest
+++ b/trinity-apps/kscope/Manifest
@@ -1 +1,2 @@
DIST kscope-trinity-14.1.1.tar.xz 1058828 BLAKE2B 4b43bd947dc48649d01b69663a47ba05383732f73687914df7daa5c25f2c5d6146d11c6dc93701dd75b78b29ded835835bd50b4b7fbcef0502abd6c05ddb648f SHA512 cc572d8d9c2438146ed1fec05f24dbb514b6e475233212afd6198652d57dc4b2002525aebf076cf235a9d88af93b92014f26429d5c912323912f8dd2f5fad528
+DIST kscope-trinity-14.1.2.tar.xz 1059208 BLAKE2B ef0eb2cc1812d9bfe2387d2dd6ee3be6924f222e88736f4cfe11420195c1869a343946615685d6f4f3457c5f9267c4e99605d6a341cd6d6efa1df9245f85dff3 SHA512 9323b7377859a0548db3e67450600f4f34f5b79f741de6b55b0bd7bdce6f324c5cc71d57c6580522d4455c72d1948dcc49e7814ddaa4ddb852a74ce3bbaec6d6
diff --git a/trinity-apps/kscope/kscope-14.1.2.ebuild b/trinity-apps/kscope/kscope-14.1.2.ebuild
new file mode 100644
index 00000000..66c9d8e8
--- /dev/null
+++ b/trinity-apps/kscope/kscope-14.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="TDE front-end to Cscope"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-util/cscope
+ dev-util/ctags
+ ~trinity-base/kate-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}