summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest1
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.0.12.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
index 214e8ec6..cecbc4db 100644
--- a/trinity-apps/kshutdown/Manifest
+++ b/trinity-apps/kshutdown/Manifest
@@ -1 +1,2 @@
DIST kshutdown-trinity-14.0.11.tar.xz 172464 BLAKE2B 0d88dc9da0e8ae374c7812c55694c109bd53f777f8e1bf9e3216569ddb6d5415aff4e744efc87cbf292b1e7f1b77cf448c6e7384bc42cb388c75a8876d44fef4 SHA512 6432b5af45b0258e7b1ee89ce70e5001cf80600c4d47ac587107c3f75266e5e793c6acf2cbd5aa9479813af1ac4699a561f944f4f19c1d7b3b57b7b0ac3c2ff5
+DIST kshutdown-trinity-14.0.12.tar.xz 172372 BLAKE2B 57477e99f7601a0c19cb53ff09237fb0e02c870d08a4b1a2ac3b38bd41b3fefccb6f3d902309ee729d89f809387e3d2c82c881f077240ea1c89f89c032445753 SHA512 95ec933fcf0c4c89912bcf95543bfdc968cd188ed533565b44682d4910d4de0f02d25e5442f9f2abda4ef8302335764aabb81cc48d8a4425a1e6c08df4e4e128
diff --git a/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild b/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild
new file mode 100644
index 00000000..2b148f08
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}