summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kstreamripper
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kstreamripper')
-rw-r--r--trinity-apps/kstreamripper/Manifest1
-rw-r--r--trinity-apps/kstreamripper/kstreamripper-14.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/trinity-apps/kstreamripper/Manifest b/trinity-apps/kstreamripper/Manifest
index d404a11d..6aa5226f 100644
--- a/trinity-apps/kstreamripper/Manifest
+++ b/trinity-apps/kstreamripper/Manifest
@@ -1 +1,2 @@
DIST kstreamripper-trinity-14.0.13.tar.xz 29076 BLAKE2B f22b4c05d3387ca75d25e39d6b3b03113e4b4ea9a6fb4681734f0a7cb4923f4b2726bbf158699f0f11ca0a3e7bbc7f40ac887cf3c20376c0628bd3af17984420 SHA512 67b3d2fd3c44430b216193cbfc42dff8544c7736c2917bd4cd73109d7b36d25863dcea5c271ec03b7404ee1d10c904f346f25ed2cc9314138501077d11116f77
+DIST kstreamripper-trinity-14.1.0.tar.xz 29080 BLAKE2B f31fd9c9f06d04d373273d9c927f7bbf70aea1e92ead32afa31ca561283c8362e0dd5ce806ddda8ed3336bbfcdc75baaaa78db9fce52f0d03e1ee55335c73594 SHA512 cf9e5f5df29bc44903612d0cbd9bbab1414080df817f73fe81631a09177353b032257c1abb4b9b8f047fd0ac099c183667e6df12de349f8ce7b030f69c3a0284
diff --git a/trinity-apps/kstreamripper/kstreamripper-14.1.0.ebuild b/trinity-apps/kstreamripper/kstreamripper-14.1.0.ebuild
new file mode 100644
index 00000000..aaceb6a5
--- /dev/null
+++ b/trinity-apps/kstreamripper/kstreamripper-14.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="TDE frontend for streamripper"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="media-sound/streamripper"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}