summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kword/kword-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kword/kword-9999.ebuild')
-rw-r--r--trinity-apps/kword/kword-9999.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/trinity-apps/kword/kword-9999.ebuild b/trinity-apps/kword/kword-9999.ebuild
index 604cb2ef..5beff015 100644
--- a/trinity-apps/kword/kword-9999.ebuild
+++ b/trinity-apps/kword/kword-9999.ebuild
@@ -1,5 +1,5 @@
-# Copyright 1999-2021 Gentoo Authors
-# Copyright 2021 The Trinity Desktop Project
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -8,7 +8,7 @@ TRINITY_MODULE_NAME="koffice"
TRINITY_MODULE_TYPE="applications/office"
TRINITY_BUILD_ADMIN="yes"
TRINITY_SUBMODULE="kword filters/kword"
-TSM_EXTRACT_ALSO="lib kspread filters/liboofilter interfaces"
+TSM_EXTRACT_ALSO="lib kspread filters/liboofilter interfaces doc"
inherit flag-o-matic trinity-meta-2
@@ -19,7 +19,7 @@ SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
-IUSE=""
+IUSE="+handbook"
DEPEND="
~trinity-apps/koffice-libs-${PV}
@@ -29,7 +29,9 @@ DEPEND="
app-text/libwpd
"
-RDEPEND="$DEPEND"
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
KMCOPYLIB="libkformula lib/kformula
libkofficecore lib/kofficecore
@@ -62,6 +64,9 @@ src_prepare() {
libname=""
fi
done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
echo "SUBDIRS=$dirlist" > ${S}/lib/Makefile.am
echo "SUBDIRS = liboofilter kword" > ${S}/filters/Makefile.am
@@ -88,3 +93,12 @@ src_compile() {
popd
trinity-meta-2_src_compile
}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}