summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kxmleditor
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kxmleditor')
-rw-r--r--trinity-apps/kxmleditor/Manifest1
-rw-r--r--trinity-apps/kxmleditor/kxmleditor-14.0.12.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/kxmleditor/Manifest b/trinity-apps/kxmleditor/Manifest
index 58ec6322..7de12a6e 100644
--- a/trinity-apps/kxmleditor/Manifest
+++ b/trinity-apps/kxmleditor/Manifest
@@ -1 +1,2 @@
DIST kxmleditor-trinity-14.0.11.tar.xz 736172 BLAKE2B 5cd2721760909587ccacb3acff946f9aca96d189226564557aa1c92b215ea9385345145f2abb8c3c605d4be157a5f5978ea90bf3269c4575a34b726b6da0b7a9 SHA512 586cc9b3b434c7854bdd39e31cbaf88a979f4201a607562a5dc851dcfb65b5e298f3bd0aa296666c4ae8c2be117e1ce91ab7a9674000e51bfa487a9df83c3424
+DIST kxmleditor-trinity-14.0.12.tar.xz 510052 BLAKE2B 7ae9941b416cbe4230eb79c3e936245b740fea13dd670d1d30ed59a080bd08dbeac449364e294a2f34e3aed7660974984c45c925b482ff094b1a41c6090283cb SHA512 c6508c0ca966201b737fa07c538888b3f2585e02f5a69b84a56bee2243004f837302c52a29e194c827e911f80d91f7a52ef475873542e4e7f6a1e659e4bfe582
diff --git a/trinity-apps/kxmleditor/kxmleditor-14.0.12.ebuild b/trinity-apps/kxmleditor/kxmleditor-14.0.12.ebuild
new file mode 100644
index 00000000..8baa9afa
--- /dev/null
+++ b/trinity-apps/kxmleditor/kxmleditor-14.0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de fr pl"
+
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="XML editor for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}