summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mathemagics
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/mathemagics')
-rw-r--r--trinity-apps/mathemagics/Manifest1
-rw-r--r--trinity-apps/mathemagics/mathemagics-14.1.0.ebuild30
-rw-r--r--trinity-apps/mathemagics/mathemagics-9999.ebuild30
-rw-r--r--trinity-apps/mathemagics/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/trinity-apps/mathemagics/Manifest b/trinity-apps/mathemagics/Manifest
new file mode 100644
index 00000000..941db5b4
--- /dev/null
+++ b/trinity-apps/mathemagics/Manifest
@@ -0,0 +1 @@
+DIST mathemagics-trinity-14.1.0.tar.xz 32780 BLAKE2B a0cf58571307e778e5b363e521768ee84c52afda38460e0912532db3b6be9c99b6bcdff84ab38af8333366034624923ef0daab6ad980cd3628c024c4531698a3 SHA512 2629aa096d87b8e6c654320b51a1bf46200ad0ef033b43058b995b02904cb3976a1a90e17de309835d65235a9d73514ab6294de8d22c2c579ef598e5764e2265
diff --git a/trinity-apps/mathemagics/mathemagics-14.1.0.ebuild b/trinity-apps/mathemagics/mathemagics-14.1.0.ebuild
new file mode 100644
index 00000000..2ed80f7a
--- /dev/null
+++ b/trinity-apps/mathemagics/mathemagics-14.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="af az bg bs ca cs da de el es et eu fi fr he hr hu is it ja \
+ lt lv mt nl nn pl pt_BR pt ro ru sk sl sr@Latn sr sv ta th \
+ tr uk wa xh zh_CN zh_TW zu"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Mathemagics is a RPN Calculator"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/mathemagics/mathemagics-9999.ebuild b/trinity-apps/mathemagics/mathemagics-9999.ebuild
new file mode 100644
index 00000000..0cc608fb
--- /dev/null
+++ b/trinity-apps/mathemagics/mathemagics-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="af az bg bs ca cs da de el es et eu fi fr he hr hu is it ja \
+ lt lv mt nl nn pl pt_BR pt ro ru sk sl sr@Latn sr sv ta th \
+ tr uk wa xh zh_CN zh_TW zu"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Mathemagics is a RPN Calculator"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/mathemagics/metadata.xml b/trinity-apps/mathemagics/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/mathemagics/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>