summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mplayerthumbs
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/mplayerthumbs')
-rw-r--r--trinity-apps/mplayerthumbs/Manifest1
-rw-r--r--trinity-apps/mplayerthumbs/mplayerthumbs-14.0.11.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/mplayerthumbs/Manifest b/trinity-apps/mplayerthumbs/Manifest
index a90815c5..6e9aa6ff 100644
--- a/trinity-apps/mplayerthumbs/Manifest
+++ b/trinity-apps/mplayerthumbs/Manifest
@@ -1 +1,2 @@
+DIST mplayerthumbs-trinity-14.0.11.tar.xz 26696 BLAKE2B f7dca9771a347b463349b402883e2e6193c3891d2aacf0fad2cbba616afcd7990012dda2062435fc4ae1dd5fe04de27a212fec528e299942f4c15d2b002f88a7 SHA512 bef72b001c8c8d4e5104efab09bdfff31a6c33289b601715f5d7cc00d9806f0b063a2a7eb91448170c8d5789999a2e8c76f1b384b4ea6aefba9fe6ad95bf1468
DIST mplayerthumbs-trinity-14.0.8.tar.xz 47244 BLAKE2B d30895bb3e2c65dd15e1733e5ed5d4e299a6f2aa20f957b3ffb9f4b2eb2b11222c759b1937536435055cf446500b5d5c2774cb180b82dea13843e7922490473d SHA512 eaf9f4f40605cc1638b28fddc10837fbc8ec8b2472e8142680cf774496b40218aa7aae0ccf59346b032eb65b4959ca88aa60cb562a27f66b2d713c0410acd9f2
diff --git a/trinity-apps/mplayerthumbs/mplayerthumbs-14.0.11.ebuild b/trinity-apps/mplayerthumbs/mplayerthumbs-14.0.11.ebuild
new file mode 100644
index 00000000..a5c800d9
--- /dev/null
+++ b/trinity-apps/mplayerthumbs/mplayerthumbs-14.0.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+TRINITY_MODULE_TYPE="applications/multimedia"
+inherit trinity-base-2
+
+DESCRIPTION="MPlayer based thumbnail generator for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="+strips"
+
+RDEPEND="media-video/mplayer"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_STRIPS_SUPPORT="$(usex strips)"
+ )
+
+ trinity-base-2_src_configure
+}