summaryrefslogtreecommitdiffstats
path: root/trinity-apps/mplayerthumbs
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/mplayerthumbs')
-rw-r--r--trinity-apps/mplayerthumbs/Manifest1
-rw-r--r--trinity-apps/mplayerthumbs/mplayerthumbs-14.0.12.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/mplayerthumbs/Manifest b/trinity-apps/mplayerthumbs/Manifest
index 130fc1ca..265dafd4 100644
--- a/trinity-apps/mplayerthumbs/Manifest
+++ b/trinity-apps/mplayerthumbs/Manifest
@@ -1 +1,2 @@
DIST mplayerthumbs-trinity-14.0.11.tar.xz 26696 BLAKE2B f7dca9771a347b463349b402883e2e6193c3891d2aacf0fad2cbba616afcd7990012dda2062435fc4ae1dd5fe04de27a212fec528e299942f4c15d2b002f88a7 SHA512 bef72b001c8c8d4e5104efab09bdfff31a6c33289b601715f5d7cc00d9806f0b063a2a7eb91448170c8d5789999a2e8c76f1b384b4ea6aefba9fe6ad95bf1468
+DIST mplayerthumbs-trinity-14.0.12.tar.xz 26620 BLAKE2B d05ac7992c550616090ec7f8b94ae8db7108abcc3fdf1435612bd37c21be62201e1f7e2379c9b664fd45b849419dba08347ee4a1c08f839fdf5a362f10df3f7b SHA512 1d3de157d62d03d7908867aec39154ba28ba22cb955a55d11c07d1ad1d8f97bf8e119ec5259fcf9cc30cace31f18c66ebaa1d3fa5167bb189c8a3b14c0516f25
diff --git a/trinity-apps/mplayerthumbs/mplayerthumbs-14.0.12.ebuild b/trinity-apps/mplayerthumbs/mplayerthumbs-14.0.12.ebuild
new file mode 100644
index 00000000..f2c6fc24
--- /dev/null
+++ b/trinity-apps/mplayerthumbs/mplayerthumbs-14.0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+TRINITY_MODULE_TYPE="applications/multimedia"
+inherit trinity-base-2
+
+DESCRIPTION="MPlayer based thumbnail generator for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+strips"
+
+RDEPEND="media-video/mplayer"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_STRIPS_SUPPORT="$(usex strips)"
+ )
+
+ trinity-base-2_src_configure
+}