summaryrefslogtreecommitdiffstats
path: root/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/smartcardauth/smartcardauth-9999.ebuild')
-rw-r--r--trinity-apps/smartcardauth/smartcardauth-9999.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/trinity-apps/smartcardauth/smartcardauth-9999.ebuild b/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
index 71ba6a12..9b42162b 100644
--- a/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
+++ b/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
@@ -1,25 +1,23 @@
+# Copyright 2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_TYPE="applications"
+TRINITY_MODULE_TYPE="applications"
inherit trinity-base-2
DESCRIPTION="SmartCard login and LUKS decrypt"
HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="|| ( GPL-2 GPL-3 )"
-
-need-trinity
-SLOT="${TRINITY_VER}"
-
-IUSE+=" libressl"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+IUSE="libressl"
-DEPEND+="
- net-libs/gnutls
+DEPEND="
dev-libs/pkcs11-helper
+ net-libs/gnutls
!libressl? ( dev-libs/openssl:= )
libressl? ( dev-libs/libressl:= )
"
-RDEPEND+=" ${DEPEND}"
+RDEPEND="${DEPEND}"