summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdeio-sword
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdeio-sword')
-rw-r--r--trinity-apps/tdeio-sword/Manifest1
-rw-r--r--trinity-apps/tdeio-sword/tdeio-sword-14.0.13.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/tdeio-sword/Manifest b/trinity-apps/tdeio-sword/Manifest
index 421d0f65..6cf3f3ea 100644
--- a/trinity-apps/tdeio-sword/Manifest
+++ b/trinity-apps/tdeio-sword/Manifest
@@ -1 +1,2 @@
DIST tdeio-sword-trinity-14.0.12.tar.xz 102736 BLAKE2B 9bb9b4ad321167c5aaa14457f769d7a618f8f39dc2565b5a7277342ff201de8adb737a84eb6f44b7722c01ccdef0e319b64ed38a72c55c33327ee01af74eccd9 SHA512 b9661d89fcb94ba26ebd19e343c5816fba8a3af6d861026fd6eb8cede8d60e2f7fbc6dcbdb816122e571e81b8e3125f70a936a367c7a4376e9617a0612aeea46
+DIST tdeio-sword-trinity-14.0.13.tar.xz 102732 BLAKE2B 4ef76aacec5187a0d4f6d881bf230e08d03579dee8868572d948319220473e84e18bf5fd5f4ccf06b1d7c08a24c2f95450e99c761974fcd42390ab4ec3db326c SHA512 87ad334efc7d2261bb887e0bb273c683ea591988d65551968647902b02c33b36250487d2cc8bb5e0490dde0785dc12c6bc2e8018d7c4f75292b8b36ec3c305a4
diff --git a/trinity-apps/tdeio-sword/tdeio-sword-14.0.13.ebuild b/trinity-apps/tdeio-sword/tdeio-sword-14.0.13.ebuild
new file mode 100644
index 00000000..8a878adc
--- /dev/null
+++ b/trinity-apps/tdeio-sword/tdeio-sword-14.0.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="Sword TDEIO plugin"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="app-text/sword"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}