summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesshaskpass
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdesshaskpass')
-rw-r--r--trinity-apps/tdesshaskpass/Manifest1
-rw-r--r--trinity-apps/tdesshaskpass/metadata.xml8
-rw-r--r--trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild34
-rw-r--r--trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild34
4 files changed, 77 insertions, 0 deletions
diff --git a/trinity-apps/tdesshaskpass/Manifest b/trinity-apps/tdesshaskpass/Manifest
new file mode 100644
index 00000000..30fa91d3
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/Manifest
@@ -0,0 +1 @@
+DIST tdesshaskpass-trinity-14.1.0.tar.xz 11152 BLAKE2B 8b85338b7e303a313c98445c3e9757f9c65c1c4ebe6886dca002be5540943fe05a2ab3a68d2ecd587d8301b4c5f20601cc8dce656f01f120ba45e00727c16501 SHA512 8c25827da3070c9e0d7677b935030da64369a62d9d6c88f29e3b58952b3f8998d2ce8c1bdf8668d332778933d94e155f77af7e7a80cddd9c52795fdcc4cf3f28
diff --git a/trinity-apps/tdesshaskpass/metadata.xml b/trinity-apps/tdesshaskpass/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild b/trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild
new file mode 100644
index 00000000..d09dcee8
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/tdesshaskpass-14.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Interactively prompt users for a passphrase for ssh-add"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-apps/acl
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild b/trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild
new file mode 100644
index 00000000..1b80941f
--- /dev/null
+++ b/trinity-apps/tdesshaskpass/tdesshaskpass-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Interactively prompt users for a passphrase for ssh-add"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-apps/acl
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}