summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn/tdesvn-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdesvn/tdesvn-9999.ebuild')
-rw-r--r--trinity-apps/tdesvn/tdesvn-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/trinity-apps/tdesvn/tdesvn-9999.ebuild b/trinity-apps/tdesvn/tdesvn-9999.ebuild
index 1ea2a2b0..4af2cc77 100644
--- a/trinity-apps/tdesvn/tdesvn-9999.ebuild
+++ b/trinity-apps/tdesvn/tdesvn-9999.ebuild
@@ -1,31 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+
TRINITY_MODULE_TYPE="applications"
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
-
inherit trinity-base-2
DESCRIPTION="Subversion client with tight TDE integration"
HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="|| ( GPL-2 GPL-3 )"
need-trinity
+LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="${TRINITY_VER}"
IUSE+=" test"
+RESTRICT+=" !test? ( test )"
DEPEND+=" dev-vcs/subversion"
RDEPEND+=" ${DEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DBUILD_TESTS="$(usex test)"
)