summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/tdesvn')
-rw-r--r--trinity-apps/tdesvn/Manifest1
-rw-r--r--trinity-apps/tdesvn/tdesvn-14.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/trinity-apps/tdesvn/Manifest b/trinity-apps/tdesvn/Manifest
index 41bea662..55835dea 100644
--- a/trinity-apps/tdesvn/Manifest
+++ b/trinity-apps/tdesvn/Manifest
@@ -1 +1,2 @@
DIST tdesvn-trinity-14.0.13.tar.xz 1380028 BLAKE2B bae6b856799078c6a5c588eb5775066abb170c84b2781252e2dc8ff7af597eb869b013e726ad7a50af7032002ae1380a63777e0b7910a4fdfee594b737a1fadf SHA512 483449ff7b8b99b56395c3cf51a2c832ea6756e517a76a167e8267da460f7c611729e962f7b059665dee4ac15250480f492d6da59aa6972ebef510e8e3f0e8da
+DIST tdesvn-trinity-14.1.0.tar.xz 1159688 BLAKE2B 6a58817353d10928f97646fb4d5ff9c588fe9a64558adf23fcdef0867fc34744a6f9000f8d64b3a991fb734edf6e70952f0e8a34146aec39b087b320ced9c868 SHA512 dbfd0766b96f4067bde3401cb19a69e0107d69a6b64ac51c8c9578dcd31e49e3feaf7518c686a522c4c7e62e42d65d85eddb4729349ade2f61e08599771fd009
diff --git a/trinity-apps/tdesvn/tdesvn-14.1.0.ebuild b/trinity-apps/tdesvn/tdesvn-14.1.0.ebuild
new file mode 100644
index 00000000..eaace786
--- /dev/null
+++ b/trinity-apps/tdesvn/tdesvn-14.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="Subversion client with tight TDE integration"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="test"
+
+RESTRICT+=" !test? ( test )"
+
+DEPEND="dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ trinity-base-2_src_configure
+}