summaryrefslogtreecommitdiffstats
path: root/trinity-apps/twin-style-dekorator
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/twin-style-dekorator')
-rw-r--r--trinity-apps/twin-style-dekorator/Manifest1
-rw-r--r--trinity-apps/twin-style-dekorator/twin-style-dekorator-14.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/trinity-apps/twin-style-dekorator/Manifest b/trinity-apps/twin-style-dekorator/Manifest
index c3c0677b..1aca7b60 100644
--- a/trinity-apps/twin-style-dekorator/Manifest
+++ b/trinity-apps/twin-style-dekorator/Manifest
@@ -1 +1,2 @@
DIST twin-style-dekorator-trinity-14.0.13.tar.xz 130928 BLAKE2B e7a888be5c04f47ab161ce29bc240e72baaf67e5b73b4c5d13b4e4090470b2f939b6ee5ba9a9c3b35039b0e7b78cf718751ea02e83d0a7b3be26af8b3b7edfbb SHA512 8982f53e3f622bfdba86972a0539872b42f0d4c61b8ce1991373ac965a4b7a85b3ec4568832245913603881e27d0ce9fff299b2f4884537543596a64532b9d83
+DIST twin-style-dekorator-trinity-14.1.0.tar.xz 130892 BLAKE2B 2940fe4f389943bff018b06d0f007bf3e07dc4e93381965ed7b782b069aa83890a70bf15ea845a0ba23a677366aaa91a5f1ec84f305a419d41c2a5e1d11e9a17 SHA512 5332a9669a9b81c01041d499ce601f58f36d41957373b3670000e7430032c12da9de6433ddf2fe016dd52ba7dff61fedeb63ac35fa46045efbb4f7d277a6e775
diff --git a/trinity-apps/twin-style-dekorator/twin-style-dekorator-14.1.0.ebuild b/trinity-apps/twin-style-dekorator/twin-style-dekorator-14.1.0.ebuild
new file mode 100644
index 00000000..90f7a7aa
--- /dev/null
+++ b/trinity-apps/twin-style-dekorator/twin-style-dekorator-14.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS=""
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="DeKorator 0.3 is a pixmap-based theme engine for TWin with its own themes"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}