summaryrefslogtreecommitdiffstats
path: root/trinity-apps/twin-style-suse2
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/twin-style-suse2')
-rw-r--r--trinity-apps/twin-style-suse2/Manifest1
-rw-r--r--trinity-apps/twin-style-suse2/twin-style-suse2-14.1.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/twin-style-suse2/Manifest b/trinity-apps/twin-style-suse2/Manifest
index 6a481dcd..9200991d 100644
--- a/trinity-apps/twin-style-suse2/Manifest
+++ b/trinity-apps/twin-style-suse2/Manifest
@@ -1 +1,2 @@
DIST twin-style-suse2-trinity-14.1.1.tar.xz 77748 BLAKE2B 4f87e73da83e474061bdcac504b733ebe5d7eadbef2dce5955822acbf6eed1c2773703000fce7d0c04ba09315989d7f6b562097defd382433442fa8db0fda720 SHA512 35ff15a027c9c18403e4b8e1caacd4aead3385111617bfe83882dfe4626e3cdd1dfed42d49a48fea914b6352d431b90024ef1b073254d7801b65984257cffd32
+DIST twin-style-suse2-trinity-14.1.2.tar.xz 73540 BLAKE2B e98b4ca623a6c24d568ad3e470fef9cdd716b78df4874f819d52cbdb20884cd0f629f7b6b330cd748c22fe844ae54fdc13c47117fee6383ad3c35858ddf9cb2d SHA512 5d6fdf3f823732ee9c0ae6aa1e2393c1adc23f1e7a2d8d1ed02401a29d89fe7caf8f9eaeddbf6fb8717a0312443283464bb6f0577517427bc1397799587ec50a
diff --git a/trinity-apps/twin-style-suse2/twin-style-suse2-14.1.2.ebuild b/trinity-apps/twin-style-suse2/twin-style-suse2-14.1.2.ebuild
new file mode 100644
index 00000000..babc7587
--- /dev/null
+++ b/trinity-apps/twin-style-suse2/twin-style-suse2-14.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="bg bs cs cy da de el en_GB en_US es et fi fr
+ he hi hr hu id it ja km ko lo lt nb nl pa pl
+ pt_BR pt ro ru sk sl sr sv ta tr uk zh_CN zh_TW"
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="TWin decoration theme from SUSE 9.3/10.0/10.1"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/twin-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}