summaryrefslogtreecommitdiffstats
path: root/trinity-base/kcheckpass/kcheckpass-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kcheckpass/kcheckpass-9999.ebuild')
-rw-r--r--trinity-base/kcheckpass/kcheckpass-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/trinity-base/kcheckpass/kcheckpass-9999.ebuild b/trinity-base/kcheckpass/kcheckpass-9999.ebuild
index ce4b8640..977be3ab 100644
--- a/trinity-base/kcheckpass/kcheckpass-9999.ebuild
+++ b/trinity-base/kcheckpass/kcheckpass-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdebase"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="A simple password checker, used by any software in need of user authentication."
-KEYWORDS=
IUSE="pam"
RDEPEND="
@@ -16,8 +16,8 @@ DEPEND="${RDEPEND}"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with pam PAM)
+ -DWITH_PAM="$(usex pam)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}