summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdelibs
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kdelibs')
-rw-r--r--trinity-base/kdelibs/Manifest2
-rw-r--r--trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch26
-rw-r--r--trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch16
-rw-r--r--trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch13
-rw-r--r--trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch44
-rw-r--r--trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch28
-rw-r--r--trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch29
-rw-r--r--trinity-base/kdelibs/kdelibs-3.5.13.1.ebuild136
-rw-r--r--trinity-base/kdelibs/kdelibs-3.5.13.2.ebuild137
-rw-r--r--trinity-base/kdelibs/metadata.xml13
10 files changed, 444 insertions, 0 deletions
diff --git a/trinity-base/kdelibs/Manifest b/trinity-base/kdelibs/Manifest
new file mode 100644
index 00000000..bd7b6990
--- /dev/null
+++ b/trinity-base/kdelibs/Manifest
@@ -0,0 +1,2 @@
+DIST kdelibs-3.5.13.1.tar.gz 16866773 SHA256 ac9540aa5da0706e257411ab70f05997a67999374e4eded915d93163cc82a84c SHA512 8b6fb1576d6f946b4d32df488f4e7c22e2db6783d075da40b4a35fef967ee222fcf73db7174b8e8d7dd6511cbd1399abf7d39c8f20517e260963734ed95c0156 WHIRLPOOL 6b2c64560af1bd24af6af6bd68e4fcbe83be48637d104028a6633ea90b79159d27afb09ed1e98462f2516fe40078b558f541f6cf3cd0f4cf1dcc7aff762c452a
+DIST kdelibs-trinity-3.5.13.2.tar.xz 13269336 SHA256 3415b04c65c9978d97cb1ca57c3fb391116a774e798c6890328c3da091a5ca9c SHA512 b6c3b9811d9a620030576ac4466fbad73b40034f1158b0278eef10363a2d67b7396ffbd2cf782d9317e95ae0f2492840e9d0cf7d7852c302d6e22ba93b11c611 WHIRLPOOL 8dc7ed209874810da9e44614e90def3f45ff688109e38c5e498bf6d14a761aae08985bc96a761c5f4763e000f7c4e9757f3a4092211c5dc6f5e80d2397af1657
diff --git a/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch
new file mode 100644
index 00000000..9d9187f8
--- /dev/null
+++ b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-OnlyShowIn-TDE.patch
@@ -0,0 +1,26 @@
+diff --git a/kinit/autostart.cpp b/kinit/autostart.cpp
+index 48325f2..d4bdb7b 100644
+--- a/kinit/autostart.cpp
++++ b/kinit/autostart.cpp
+@@ -178,7 +178,7 @@ AutoStart::loadAutoStartList()
+
+ if (config.hasKey("OnlyShowIn"))
+ {
+- if ((!config.readListEntry("OnlyShowIn", ';').contains("TDE")) && (!config.readListEntry("OnlyShowIn", ';').contains("KDE")))
++ if (!config.readListEntry("OnlyShowIn", ';').contains("TDE"))
+ continue;
+ }
+ if (config.hasKey("NotShowIn"))
+diff --git a/kio/kio/kservicegroup.cpp b/kio/kio/kservicegroup.cpp
+index 6758ca1..18b402b 100644
+--- a/kio/kio/kservicegroup.cpp
++++ b/kio/kio/kservicegroup.cpp
+@@ -84,7 +84,7 @@ KServiceGroup::KServiceGroup( const TQString &configFile, const TQString & _relp
+ TQStringList tmpList;
+ if (config.hasKey("OnlyShowIn"))
+ {
+- if ((!config.readListEntry("OnlyShowIn", ';').contains("TDE")) && (!config.readListEntry("OnlyShowIn", ';').contains("KDE")))
++ if (!config.readListEntry("OnlyShowIn", ';').contains("TDE"))
+ d->m_bNoDisplay = true;
+ }
+ if (config.hasKey("NotShowIn"))
diff --git a/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch
new file mode 100644
index 00000000..094708cc
--- /dev/null
+++ b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-bug-1161.patch
@@ -0,0 +1,16 @@
+diff --git a/kdeui/ksharedpixmap.cpp b/kdeui/ksharedpixmap.cpp
+index 29c6702..64c54e1 100644
+--- a/kdeui/ksharedpixmap.cpp
++++ b/kdeui/ksharedpixmap.cpp
+@@ -160,9 +160,8 @@ bool KSharedPixmap::x11Event(XEvent *event)
+ void *drawable_id = (void *) pixmap_id;
+ Drawable pixmap = *(Drawable*) drawable_id;
+
+- Status status = XGetGeometry(qt_xdisplay(), pixmap, &root, &dummy, &dummy, &width, &height, &udummy, &udummy);
+-
+- if (status == BadDrawable)
++ if (!XGetGeometry(qt_xdisplay(), pixmap, &root, &dummy, &dummy,
++ &width, &height, &udummy, &udummy))
+ return false;
+
+ if (d->rect.isEmpty())
diff --git a/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch
new file mode 100644
index 00000000..2247b898
--- /dev/null
+++ b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-insane-kde4-variables.patch
@@ -0,0 +1,13 @@
+diff --git a/kio/kio/kservice.cpp b/kio/kio/kservice.cpp
+index 4964103..368fe9a 100644
+--- a/kio/kio/kservice.cpp
++++ b/kio/kio/kservice.cpp
+@@ -198,7 +198,7 @@ KService::init( KDesktopFile *config )
+
+ m_strExec = config->readPathEntry( "Exec" );
+ if (kde4application && !m_strExec.startsWith("/")) {
+- m_strExec = "KDEHOME=$HOME/.kde XDG_DATA_DIRS=/usr/share KDEDIRS=/usr/ XDG_CONFIG_DIRS=/etc/xdg/ PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:$PATH "+m_strExec;
++ m_strExec = "KDEHOME=$HOME/.kde4 XDG_DATA_DIRS=/usr/share KDEDIRS=/usr/ XDG_CONFIG_DIRS=/etc/xdg/ PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:$PATH "+m_strExec;
+ } else if (config->readBoolEntry("X-KDE-SubstituteUID")) {
+ int space = m_strExec.find(" ");
+ if (space==-1)
diff --git a/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch
new file mode 100644
index 00000000..e359a628
--- /dev/null
+++ b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-fix-no-xcomposite.patch
@@ -0,0 +1,44 @@
+--- kdecore/kapplication.cpp.orig 2012-10-26 11:49:24.000000000 +0400
++++ kdecore/kapplication.cpp 2012-10-26 11:49:33.000000000 +0400
+@@ -186,7 +186,7 @@
+ static Atom kde_xdnd_drop;
+ #endif
+
+-#ifdef Q_WS_X11
++#if defined(Q_WS_X11) && defined(COMPOSITE)
+ static int composite_event, composite_error, composite_opcode;
+ static bool x11_composite_error_generated;
+ static int x11_error(Display *dpy, XErrorEvent *ev) {
+@@ -1981,7 +1981,7 @@
+ return false;
+ }
+
+-bool KApplication::detectCompositionManagerAvailable(bool force_available) {
++bool KApplication::detectCompositionManagerAvailable(bool force_available, bool /* available */) {
+ const char *home;
+ struct passwd *p;
+ p = getpwuid(getuid());
+@@ -2023,21 +2023,17 @@
+ return 0;
+ }
+
+-Qt::HANDLE KApplication::getX11RGBAVisual(char *display) {
++Qt::HANDLE KApplication::getX11RGBAVisual(Display *dpy) {
+ return 0;
+ }
+
+-Qt::HANDLE KApplication::getX11RGBAColormap(char *display) {
++Qt::HANDLE KApplication::getX11RGBAColormap(Display *dpy) {
+ return 0;
+ }
+
+ bool KApplication::isX11CompositionAvailable() {
+ return false;
+ }
+-
+-KApplication KApplication::KARGBApplication( bool allowStyles ) {
+- return KApplication::KApplication(allowStyles, true);
+-}
+ #endif
+
+ static bool kapp_block_user_input = false;
diff --git a/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch
new file mode 100644
index 00000000..1b7e1c91
--- /dev/null
+++ b/trinity-base/kdelibs/files/kdelibs-3.5.13.1-make-xcomposite-optional.patch
@@ -0,0 +1,28 @@
+--- CMakeLists.txt.orig 2012-10-25 09:20:57.773606598 +0400
++++ CMakeLists.txt 2012-10-26 07:18:14.793762688 +0400
+@@ -81,5 +81,6 @@
+ OPTION( WITH_ASPELL "Enable aspell support" OFF )
+ OPTION( WITH_HSPELL "Enable hspell support" OFF )
++OPTION( WITH_XCOMPOSITE "Enable xcomposite support" ${WITH_ALL_OPTIONS} )
+
+
+ ##### set PKG_CONFIG_PATH #######################
+@@ -564,10 +565,14 @@
+
+ ##### check for xcomposite #########################
+
+-pkg_search_module( XCOMPOSITE xcomposite )
+-if( XCOMPOSITE_FOUND )
+- set( HAVE_XCOMPOSITE 1 )
+-endif( XCOMPOSITE_FOUND )
++if( WITH_XCOMPOSITE )
++ pkg_search_module( XCOMPOSITE xcomposite )
++ if( XCOMPOSITE_FOUND )
++ set( HAVE_XCOMPOSITE 1 )
++ else()
++ message(FATAL_ERROR "\nxcomposite support was requested, but xcomposite was not found on your system" )
++ endif( XCOMPOSITE_FOUND )
++endif( WITH_XCOMPOSITE )
+
+ ##### check for libxml-2.0 ######################
+
diff --git a/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch b/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch
new file mode 100644
index 00000000..c635b003
--- /dev/null
+++ b/trinity-base/kdelibs/files/kdelibs-3.5.13.2-make-xcomposite-optional.patch
@@ -0,0 +1,29 @@
+--- CMakeLists.txt.orig 2013-05-09 23:16:28.000000000 +0400
++++ CMakeLists.txt 2013-06-28 04:17:31.677764189 +0400
+@@ -85,6 +85,7 @@
+
+ OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
+ OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
++OPTION( WITH_XCOMPOSITE "Enable xcomposite support" ${WITH_ALL_OPTIONS} )
+
+ set( KDE4_DEFAULT_HOME ".kde" CACHE PATH "KDE4 home directory passed as KDEHOME to kde4 applications" )
+
+@@ -588,10 +589,14 @@
+
+ ##### check for xcomposite #########################
+
+-pkg_search_module( XCOMPOSITE xcomposite )
+-if( XCOMPOSITE_FOUND )
+- set( HAVE_XCOMPOSITE 1 )
+-endif( XCOMPOSITE_FOUND )
++if( WITH_XCOMPOSITE )
++ pkg_search_module( XCOMPOSITE xcomposite )
++ if( XCOMPOSITE_FOUND )
++ set( HAVE_XCOMPOSITE 1 )
++ else()
++ message(FATAL_ERROR "\nxcomposite support was requested, but xcomposite was not found on your system" )
++ endif( XCOMPOSITE_FOUND )
++endif( WITH_XCOMPOSITE )
+
+ ##### check for libxml-2.0 ######################
+
diff --git a/trinity-base/kdelibs/kdelibs-3.5.13.1.ebuild b/trinity-base/kdelibs/kdelibs-3.5.13.1.ebuild
new file mode 100644
index 00000000..5b042be4
--- /dev/null
+++ b/trinity-base/kdelibs/kdelibs-3.5.13.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="$PN"
+
+inherit trinity-base multilib
+
+set-trinityver
+
+DESCRIPTION="Trinity libraries needed by all TDE programs."
+HOMEPAGE="http://www.trinitydesktop.org/"
+LICENSE="GPL-2 LGPL-2"
+SLOT="$TRINITY_VER"
+KEYWORDS="x86 amd64"
+IUSE="alsa avahi arts cups fam jpeg2k lua openexr spell sudo tiff utempter
+ xcomposite"
+
+DEPEND="${DEPEND}
+ =dev-qt/tqtinterface-${TRINITY_VER}*
+ >=dev-libs/libxslt-1.1.16
+ >=dev-libs/libxml2-2.6.6
+ >=dev-libs/libpcre-6.6
+ media-libs/libart_lgpl
+ net-dns/libidn
+ app-text/ghostscript-gpl
+ >=dev-libs/openssl-0.9.7d:=
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libart_lgpl
+ x11-libs/libXcursor
+ alsa? ( media-libs/alsa-lib )
+ arts? ( trinity-base/arts:= )
+ avahi? ( net-dns/avahi )
+ cups? ( >=net-print/cups-1.1.19 )
+ fam? ( virtual/fam )
+ jpeg2k? ( media-libs/jasper )
+ lua? ( dev-lang/lua:* )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ spell? ( >=app-dicts/aspell-en-6.0.0 >=app-text/aspell-0.60.5 )
+ sudo? ( app-admin/sudo )
+ tiff? ( media-libs/tiff:= )
+ utempter? ( sys-libs/libutempter )
+ xcomposite? ( x11-libs/libXcomposite )"
+# NOTE: upstream lacks avahi support, so the use flag is currenly masked
+
+RDEPEND="${DEPEND}"
+
+PATCHES=( "$FILESDIR/${PN}-3.5.13.1-make-xcomposite-optional.patch"
+ "$FILESDIR/${PN}-3.5.13.1-fix-no-xcomposite.patch"
+ "$FILESDIR/${PN}-3.5.13.1-OnlyShowIn-TDE.patch"
+ "$FILESDIR/${PN}-3.5.13.1-bug-1161.patch"
+ "$FILESDIR/${PN}-3.5.13.1-fix-insane-kde4-variables.patch")
+
+src_configure() {
+ mycmakeargs=(
+ -DMALLOC_FULL=ON
+ -DWITH_LIBIDN=ON
+ -DWITH_SSL=ON
+ -DWITH_LIBART=ON
+ -DWITH_PCRE=ON
+ -DWITH_XCURSOR=ON
+ -DWITH_HSPELL=OFF
+ $(cmake-utils_use_with alsa ALSA)
+ $(cmake-utils_use_with arts ARTS)
+ $(cmake-utils_use_with avahi AVAHI)
+ $(cmake-utils_use_with cups CUPS)
+ $(cmake-utils_use_with kernel_linux INOTIFY)
+ $(cmake-utils_use_with jpeg2k JASPER)
+ $(cmake-utils_use_with lua LUA)
+ $(cmake-utils_use_with openexr OPENEXR)
+ $(cmake-utils_use_with spell ASPELL)
+ $(cmake-utils_use_with fam GAMIN)
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with utempter UTEMPTER)
+ $(cmake-utils_use_with xcomposite XCOMPOSITE)
+ $(cmake-utils_use_with sudo SUDO_KDESU_BACKEND)
+ )
+
+ trinity-base_src_configure
+}
+
+src_install() {
+ trinity-base_src_install
+
+ dodir /etc/env.d
+ # KDE implies that the install path is listed first in TDEDIRS and the user
+ # directory (implicitly added) to be the last entry. Doing otherwise breaks
+ # certain functionality. Do not break this (once again *sigh*), but read the code.
+ # KDE saves the installed path implicitly and so this is not needed, /usr
+ # is set in ${TDEDIR}/share/config/kdeglobals and so TDEDIRS is not needed.
+
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${TDEDIR}/${libdir}:${libdirs}"
+ done
+
+ # number goes down with version upgrade
+ # NOTE: they should be less than kdepaths for kde-3.5
+ cat <<EOF > "${D}/etc/env.d/42trinitypaths-${SLOT}"
+PATH=${TDEDIR}/bin
+ROOTPATH=${TDEDIR}/sbin:${TDEDIR}/bin
+LDPATH=${libdirs#:}
+MANPATH=${TDEDIR}/share/man
+CONFIG_PROTECT="${TDEDIR}/share/config ${TDEDIR}/env ${TDEDIR}/shutdown /usr/share/config"
+#TDE_IS_PRELINKED=1
+# Excessive flushing to disk as in releases before KDE 3.5.10. Usually you don't want that.
+#TDE_EXTRA_FSYNC=1
+XDG_DATA_DIRS="${TDEDIR}/share"
+EOF
+
+ # Make sure the target for the revdep-rebuild stuff exists. Fixes bug 184441.
+ dodir /etc/revdep-rebuild
+
+cat <<EOF > "${D}/etc/revdep-rebuild/50-trinity-${SLOT}"
+SEARCH_DIRS="${TDEDIR}/bin ${TDEDIR}/lib*"
+EOF
+
+ # make documentation help accessible throught symlink
+ dosym ${TDEDIR}/share/doc/kde/HTML ${TDEDIR}/share/doc/HTML
+
+ trinity-base_create_tmp_docfiles
+ trinity-base_install_docfiles
+}
+
+pkg_postinst () {
+ if use sudo; then
+ einfo "Remember sudo use flag sets only the defauld value"
+ einfo "It can be overriden on a user-level by adding:"
+ einfo " [super-user-command]"
+ einfo " super-user-command=su"
+ einfo "To the kdeglobal config file which is should be usually"
+ einfo "located in the ~/.trinity/share/config/ directory."
+ fi
+}
diff --git a/trinity-base/kdelibs/kdelibs-3.5.13.2.ebuild b/trinity-base/kdelibs/kdelibs-3.5.13.2.ebuild
new file mode 100644
index 00000000..9d3933ed
--- /dev/null
+++ b/trinity-base/kdelibs/kdelibs-3.5.13.2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="$PN"
+
+inherit trinity-base multilib
+
+set-trinityver
+
+DESCRIPTION="Trinity libraries needed by all TDE programs."
+HOMEPAGE="http://www.trinitydesktop.org/"
+LICENSE="GPL-2 LGPL-2"
+SLOT="${TRINITY_VER}"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa avahi arts cups fam jpeg2k lua lzma openexr spell sudo tiff utempter
+ xcomposite"
+
+DEPEND="${DEPEND}
+ =dev-qt/tqtinterface-${TRINITY_VER}*
+ >=dev-libs/libxslt-1.1.16
+ >=dev-libs/libxml2-2.6.6
+ >=dev-libs/libpcre-6.6
+ media-libs/libart_lgpl
+ net-dns/libidn
+ app-text/ghostscript-gpl
+ >=dev-libs/openssl-0.9.7d:=
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libart_lgpl
+ x11-libs/libXcursor
+ alsa? ( media-libs/alsa-lib )
+ arts? ( trinity-base/arts:= )
+ avahi? ( net-dns/avahi )
+ cups? ( >=net-print/cups-1.1.19 )
+ fam? ( virtual/fam )
+ jpeg2k? ( media-libs/jasper )
+ lua? ( dev-lang/lua:* )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ spell? ( >=app-dicts/aspell-en-6.0.0 >=app-text/aspell-0.60.5 )
+ sudo? ( app-admin/sudo )
+ tiff? ( media-libs/tiff:= )
+ utempter? ( sys-libs/libutempter )
+ xcomposite? ( x11-libs/libXcomposite )
+ lzma? ( app-arch/xz-utils )"
+# NOTE: upstream lacks avahi support, so the use flag is currenly masked
+
+RDEPEND="${DEPEND}"
+
+PATCHES=( "$FILESDIR/${PN}-3.5.13.2-make-xcomposite-optional.patch"
+ "$FILESDIR/${PN}-3.5.13.1-fix-no-xcomposite.patch"
+ "$FILESDIR/${PN}-3.5.13.1-OnlyShowIn-TDE.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ -DMALLOC_FULL=ON
+ -DWITH_LIBIDN=ON
+ -DWITH_SSL=ON
+ -DWITH_LIBART=ON
+ -DWITH_PCRE=ON
+ -DWITH_XCURSOR=ON
+ -DWITH_HSPELL=OFF
+ -DKDE4_DEFAULT_HOME=.kde4
+ $(cmake-utils_use_with alsa ALSA)
+ $(cmake-utils_use_with arts ARTS)
+ $(cmake-utils_use_with avahi AVAHI)
+ $(cmake-utils_use_with cups CUPS)
+ $(cmake-utils_use_with kernel_linux INOTIFY)
+ $(cmake-utils_use_with jpeg2k JASPER)
+ $(cmake-utils_use_with lua LUA)
+ $(cmake-utils_use_with lzma LZMA)
+ $(cmake-utils_use_with openexr OPENEXR)
+ $(cmake-utils_use_with spell ASPELL)
+ $(cmake-utils_use_with fam GAMIN)
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with utempter UTEMPTER)
+ $(cmake-utils_use_with xcomposite XCOMPOSITE)
+ $(cmake-utils_use_with sudo SUDO_KDESU_BACKEND)
+ )
+
+ trinity-base_src_configure
+}
+
+src_install() {
+ trinity-base_src_install
+
+ dodir /etc/env.d
+ # KDE implies that the install path is listed first in TDEDIRS and the user
+ # directory (implicitly added) to be the last entry. Doing otherwise breaks
+ # certain functionality. Do not break this (once again *sigh*), but read the code.
+ # KDE saves the installed path implicitly and so this is not needed, /usr
+ # is set in ${TDEDIR}/share/config/kdeglobals and so TDEDIRS is not needed.
+
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${TDEDIR}/${libdir}:${libdirs}"
+ done
+
+ # number goes down with version upgrade
+ # NOTE: they should be less than kdepaths for kde-3.5
+ cat <<EOF > "${D}/etc/env.d/42trinitypaths-${SLOT}"
+PATH=${TDEDIR}/bin
+ROOTPATH=${TDEDIR}/sbin:${TDEDIR}/bin
+LDPATH=${libdirs#:}
+MANPATH=${TDEDIR}/share/man
+CONFIG_PROTECT="${TDEDIR}/share/config ${TDEDIR}/env ${TDEDIR}/shutdown /usr/share/config"
+#TDE_IS_PRELINKED=1
+# Excessive flushing to disk as in releases before KDE 3.5.10. Usually you don't want that.
+#TDE_EXTRA_FSYNC=1
+XDG_DATA_DIRS="${TDEDIR}/share"
+EOF
+
+ # Make sure the target for the revdep-rebuild stuff exists. Fixes bug 184441.
+ dodir /etc/revdep-rebuild
+
+cat <<EOF > "${D}/etc/revdep-rebuild/50-trinity-${SLOT}"
+SEARCH_DIRS="${TDEDIR}/bin ${TDEDIR}/lib*"
+EOF
+
+ # make documentation help accessible throught symlink
+ dosym ${TDEDIR}/share/doc/kde/HTML ${TDEDIR}/share/doc/HTML
+
+ trinity-base_create_tmp_docfiles
+ trinity-base_install_docfiles
+}
+
+pkg_postinst () {
+ if use sudo; then
+ einfo "Remember sudo use flag sets only the defauld value"
+ einfo "It can be overriden on a user-level by adding:"
+ einfo " [super-user-command]"
+ einfo " super-user-command=su"
+ einfo "To the kdeglobal config file which is should be usually"
+ einfo "located in the ~/.trinity/share/config/ directory."
+ fi
+}
diff --git a/trinity-base/kdelibs/metadata.xml b/trinity-base/kdelibs/metadata.xml
new file mode 100644
index 00000000..ac4ddb96
--- /dev/null
+++ b/trinity-base/kdelibs/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+ <use>
+ <flag name="sudo"> Use <pkg>app-admin/sudo</pkg> as a default program to
+ obtain root privileges.</flag>
+ <flag name="utempter">Records user logins. Useful on multi-user systems</flag>
+ </use>
+</pkgmetadata>