summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop/kdesktop-14.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kdesktop/kdesktop-14.0.8.ebuild')
-rw-r--r--trinity-base/kdesktop/kdesktop-14.0.8.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/trinity-base/kdesktop/kdesktop-14.0.8.ebuild b/trinity-base/kdesktop/kdesktop-14.0.8.ebuild
deleted file mode 100644
index fa1e5ac6..00000000
--- a/trinity-base/kdesktop/kdesktop-14.0.8.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Copyright 2020 The Trinity Desktop Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-TRINITY_MODULE_NAME="tdebase"
-
-inherit trinity-meta-2
-
-DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
-KEYWORDS="~amd64 ~x86"
-IUSE="pam xscreensaver"
-
-COMMON_DEPEND="x11-libs/libXrender
- x11-libs/libXcursor
- ~dev-libs/dbus-1-tqt-${PV}
- ~trinity-base/libkonq-${PV}
- ~trinity-base/kcontrol-${PV}
- xscreensaver? ( x11-libs/libXScrnSaver )"
- # Requires the desktop background settings module,
- # so until we separate the kcontrol modules into separate ebuilds :-),
- # there's a dep here
-DEPEND="${COMMON_DEPEND}
- xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
-RDEPEND="${COMMON_DEPEND}
- ~trinity-base/kcheckpass-${PV}
- ~trinity-base/kdialog-${PV}
- ~trinity-base/konqueror-${PV}
- pam? ( trinity-base/tdebase-pam )"
-
-TSM_EXTRACT_ALSO="kcheckpass/ FindXscreensaver.cmake"
-
-src_configure() {
- mycmakeargs=(
- -DWITH_XCURSOR=ON
- -DWITH_XRENDER=ON
- -DWITH_PAM="$(usex pam)"
- -DWITH_XSCREENSAVER="$(usex xscreensaver)"
- -DTDESCREENSAVER_PAM_SERVICE=tde
- )
-
- trinity-meta-2_src_configure
-}