summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop/kdesktop-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kdesktop/kdesktop-9999.ebuild')
-rw-r--r--trinity-base/kdesktop/kdesktop-9999.ebuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/trinity-base/kdesktop/kdesktop-9999.ebuild b/trinity-base/kdesktop/kdesktop-9999.ebuild
index 9b2e26d8..9ef07666 100644
--- a/trinity-base/kdesktop/kdesktop-9999.ebuild
+++ b/trinity-base/kdesktop/kdesktop-9999.ebuild
@@ -1,31 +1,29 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdebase"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
-KEYWORDS=
IUSE="pam xscreensaver"
COMMON_DEPEND="x11-libs/libXrender
x11-libs/libXcursor
- >=trinity-base/libkonq-${PV}:${SLOT}
- >=trinity-base/kcontrol-${PV}:${SLOT}
+ =trinity-base/libkonq-${PV}
+ =trinity-base/kcontrol-${PV}
xscreensaver? ( x11-libs/libXScrnSaver )"
# Requires the desktop background settings module,
# so until we separate the kcontrol modules into separate ebuilds :-),
# there's a dep here
DEPEND="${COMMON_DEPEND}
- xscreensaver? ( x11-base/xorg-proto )
- xscreensaver? ( x11-misc/xscreensaver )"
-# TODO remove x11-misc/xscreensaver after TDE bug # will be fixed
+ xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
RDEPEND="${COMMON_DEPEND}
- >=trinity-base/kcheckpass-${PV}:${SLOT}
- >=trinity-base/kdialog-${PV}:${SLOT}
- >=trinity-base/konqueror-${PV}:${SLOT}
+ =trinity-base/kcheckpass-${PV}
+ =trinity-base/kdialog-${PV}
+ =trinity-base/konqueror-${PV}
pam? ( trinity-base/tdebase-pam )"
TSM_EXTRACT_ALSO="kcheckpass/"
@@ -34,9 +32,9 @@ src_configure() {
mycmakeargs=(
-DWITH_XCURSORS=ON
-DWITH_XRENDER=ON
- $(cmake-utils_use_with pam PAM)
- $(cmake-utils_use_with xscreensaver XSCREENSAVER)
+ -DWITH_PAM="$(usex pam)"
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}