summaryrefslogtreecommitdiffstats
path: root/trinity-base/ksplashml/ksplashml-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/ksplashml/ksplashml-9999.ebuild')
-rw-r--r--trinity-base/ksplashml/ksplashml-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/trinity-base/ksplashml/ksplashml-9999.ebuild b/trinity-base/ksplashml/ksplashml-9999.ebuild
index ea3bd4e3..9aa49363 100644
--- a/trinity-base/ksplashml/ksplashml-9999.ebuild
+++ b/trinity-base/ksplashml/ksplashml-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdebase"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity splashscreen framework (of Trinity itself, not of individual apps)"
-KEYWORDS=
+
IUSE="xinerama"
DEPEND="x11-libs/libXcursor
@@ -16,8 +17,8 @@ RDEPEND="$DEPEND"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with xinerama XINERAMA)
+ -DWITH_XINERAMA="$(usex xinerama)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}