summaryrefslogtreecommitdiffstats
path: root/trinity-base/tde-i18n/tde-i18n-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/tde-i18n/tde-i18n-9999.ebuild')
-rw-r--r--trinity-base/tde-i18n/tde-i18n-9999.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/trinity-base/tde-i18n/tde-i18n-9999.ebuild b/trinity-base/tde-i18n/tde-i18n-9999.ebuild
index d6122aa0..dfcd88df 100644
--- a/trinity-base/tde-i18n/tde-i18n-9999.ebuild
+++ b/trinity-base/tde-i18n/tde-i18n-9999.ebuild
@@ -3,24 +3,20 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tde-i18n"
-inherit trinity-base-2
+TRINITY_LANGS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et
+ eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms
+ nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta te
+ tg th tr uk uz uz@cyrillic vi wa zh_CN zh_TW"
-set-trinityver
+TRINITY_MODULE_NAME="tde-i18n"
+inherit trinity-base-2
DESCRIPTION="Trinity internationalization package"
HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="|| ( GPL-2 GPL-3 )"
-
-SLOT="${TRINITY_VER}"
-need-trinity
-
-TRINITY_LANGS="af ar az be bg bn br bs ca cs csb cy da de el en_GB eo es et
- eu fa fi fr fy ga gl he hi hr hu is it ja kk km ko lt lv mk mn ms
- nb nds nl nn pa pl pt pt_BR ro ru rw se sk sl sr sr@Latn ss sv ta te
- tg th tr uk uz uz@cyrillic vi wa zh_CN zh_TW"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
for X in ${TRINITY_LANGS} ; do
IUSE="${IUSE} l10n_${X}"
@@ -36,7 +32,7 @@ run_phase() {
CMAKE_USE_DIR="${S}/${dir}"
BUILD_DIR="${WORKDIR}/${dir}-build"
trinity-base-2_${phase}
- popd
+ popd || die
}
src_prepare() {
@@ -45,7 +41,7 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=( -DBUILD_ALL=ON )
+ local mycmakeargs=( -DBUILD_ALL=ON )
trinity_l10n_for_each_locale_do run_phase src_configure
}