summaryrefslogtreecommitdiffstats
path: root/trinity-base/twin
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/twin')
-rw-r--r--trinity-base/twin/Manifest2
-rw-r--r--trinity-base/twin/twin-14.0.6.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/trinity-base/twin/Manifest b/trinity-base/twin/Manifest
new file mode 100644
index 00000000..b2bbd5ea
--- /dev/null
+++ b/trinity-base/twin/Manifest
@@ -0,0 +1,2 @@
+DIST tdebase-trinity-14.0.6.tar.xz 30023524 BLAKE2B 7be823f5e5d2555a7cbcf9ae08cfc5999e3d08da3ad4546ca357a228d37291bc6553f0ccda2924683f00db6c3dce59c42420858a48badad99e318488b5c1656e SHA512 ac49887ef407fd5290ca1cb95121ad7eac17d41a4be95caaa21f42559ab5904d93d152bdfd63d79f0d5e761653031a2c620fcb7bcec933dc97cf9307606bc14d
+DIST tdebase-trinity-14.0.7.tar.xz 30025772 BLAKE2B d163bb263ef0351dcf437777e7dbf5da4681baa2023cb2d53357145fec25a5ecb7015832645862b912b25b0d2f61432c6e4b740fad4c84b153610dc3be30c60a SHA512 ce9fbac0553b49c21061cf5cf22acf0831b6a2984ac08df3d37a1ed28ed1e7066cfc9cfb7fc3c78e40b876553dee6c3b1bd9e6fc5419af310645ac704a2abdb7
diff --git a/trinity-base/twin/twin-14.0.6.ebuild b/trinity-base/twin/twin-14.0.6.ebuild
new file mode 100644
index 00000000..e12174ce
--- /dev/null
+++ b/trinity-base/twin/twin-14.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="7"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta-2 eutils
+
+DESCRIPTION="Trinity window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="xcomposite xrandr xinerama +libconfig +pcre opengl"
+
+DEPEND="x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-base/xorg-proto )
+ xrandr? ( x11-libs/libXrandr )
+ libconfig? ( dev-libs/libconfig )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre[jit] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ -DWITH_XFIXES="$(usex xcomposite)"
+ -DWITH_XRENDER="$(usex xcomposite)"
+ -DWITH_XRANDR="$(usex xrandr)"
+ -DWITH_LIBCONFIG="$(usex libconfig)"
+ -DWITH_PCRE="$(usex pcre)"
+ -DWITH_XINERAMA="$(usex xinerama)"
+ )
+
+ trinity-meta-2_src_configure
+}
+
+pkg_postinst() {
+ if ! use xcomposite; then
+ for flag in xrandr xinerama libconfig pcre opengl; do
+ use $flag && \
+ ewarn "USE=\"$flag\" is passed, but it doesn't change anything due to" && \
+ ewarn "$flag support in ${P} take effect only if composite is enabled."
+ done
+
+ fi
+}