summaryrefslogtreecommitdiffstats
path: root/x11-libs
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/tqscintilla/Manifest1
-rw-r--r--x11-libs/tqscintilla/tqscintilla-14.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/tqscintilla/Manifest b/x11-libs/tqscintilla/Manifest
index 46488e3e..db25180e 100644
--- a/x11-libs/tqscintilla/Manifest
+++ b/x11-libs/tqscintilla/Manifest
@@ -1 +1,2 @@
DIST tqscintilla-trinity-14.0.13.tar.xz 654328 BLAKE2B 9e0ba9a459aeb17a35a8d237490a85ddd383b570427fddc66c2943649a064f564d1612c6b67abd41e99c2e2b293e77c18cc3d46a7fb6d07888cf078ae6353d55 SHA512 41bf8b6f3bb63b25100ce7cc8228dc4043e8a751fae33189ca4e9465ae09bd1020c6bd21e87e81330b986bef71ed188dd5b2c18f76e553035c4404632fe95ca5
+DIST tqscintilla-trinity-14.1.0.tar.xz 653968 BLAKE2B a666c6fb2f199795e6569e646bb89a04bb85277d50b77d17becf56abae3b06a2cb64212772d80c41e79c2dc95e610bc394111a2d90ff8d5103f89a84750ca77b SHA512 3dda53d4901f54393d45ea186690c5b55ad403c9dcfb1585d119ef34b7aa101228af505e94ed8302c7486dfa3874962a85f00462fe03701093e0efaf30626b10
diff --git a/x11-libs/tqscintilla/tqscintilla-14.1.0.ebuild b/x11-libs/tqscintilla/tqscintilla-14.1.0.ebuild
new file mode 100644
index 00000000..e5b7f661
--- /dev/null
+++ b/x11-libs/tqscintilla/tqscintilla-14.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="tqscintilla"
+
+inherit trinity-base-2
+
+DESCRIPTION="TQt source code editing component based on Scintilla"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}${TQBASE}"
+ -DHTML_INSTALL_DIR="${TDEDIR}/share/doc/tde/HTML"
+ -DBUILD_ALL=ON
+ )
+ trinity-base-2_src_configure
+}