summaryrefslogtreecommitdiffstats
path: root/arch/tde-extra/tde-tdmtheme/PKGBUILD
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-09-20 17:08:32 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-09-29 09:27:25 +0200
commit0ac2945504b4df71d0ac6777b2c956cd4921ad08 (patch)
tree301eb3b41ae6f4e78a8b5611040ba8d9c13af6dd /arch/tde-extra/tde-tdmtheme/PKGBUILD
parent318e997cf4d25c5d2e7b4261a6017b653c1fa93c (diff)
downloadtde-packaging-0ac2945504b4df71d0ac6777b2c956cd4921ad08.tar.gz
tde-packaging-0ac2945504b4df71d0ac6777b2c956cd4921ad08.zip
ArchLinux: Take a newer state of pkgbuilds from Michael Manley
Clean old long-term not maintained pkgbuilds. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 018f946ee70600993c60a74046f417ca05bdb41b)
Diffstat (limited to 'arch/tde-extra/tde-tdmtheme/PKGBUILD')
-rw-r--r--arch/tde-extra/tde-tdmtheme/PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/arch/tde-extra/tde-tdmtheme/PKGBUILD b/arch/tde-extra/tde-tdmtheme/PKGBUILD
new file mode 100644
index 000000000..aa991c312
--- /dev/null
+++ b/arch/tde-extra/tde-tdmtheme/PKGBUILD
@@ -0,0 +1,56 @@
+# Contributor: e1z0 <justinas at eofnet dot lt>
+
+pkgname=tde-tdmtheme
+pkgver=14.0.5
+pkgrel=1
+pkgdesc="TDM Theme"
+arch=('i686' 'x86_64')
+url='http://scm.trinitydesktop.org/scm/git/applications/tdmtheme'
+license=('GPL')
+groups=('tde-extra')
+depends=('tde-tdebase')
+makedepends=('pkgconfig' 'automake')
+#provides=('tdmtheme')
+#conflicts=('tdmtheme')
+#replaces=('tdmtheme')
+options=('staticlibs' 'libtool' '!strip')
+source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/applications/tdmtheme-R${pkgver}.tar.bz2")
+md5sums=('dc202459e80fde7b469ef1cfb684803c')
+# install=''
+
+build() {
+ # old ruby1.8 path
+ export PATH=/opt/ruby1.8/bin:$PATH
+ ## Generate config files and update with autoreconf
+ cd ${srcdir}/applications/${pkgname#*-}
+
+ msg "Copying system libtool files...."
+ cp /usr/share/aclocal/libtool.m4 ./admin/libtool.m4.in
+ cp /usr/share/libtool/build-aux/ltmain.sh ./admin/ltmain.sh
+
+ msg "Running make -f admin/Makefile.common ...."
+ make -f admin/Makefile.common
+
+ ## configure
+ msg "Configuring - ${pkgname#*-}..."
+ CFLAGS="${CFLAGS} -fpermissive" \
+ CXXFLAGS="${CXXFLAGS} -fpermissive" \
+ ./configure \
+ --prefix=${TDEDIR} \
+ --with-qt-dir=${QTDIR} \
+ --with-qt-includes=${QTDIR}/include \
+ --with-qt-libraries=${QTDIR}/lib \
+ --sysconfdir=${TDEDIR}/etc \
+ --localstatedir=/var \
+ --enable-closure
+
+ msg "Building - ${pkgname#*-}..."
+make $NUMJOBS
+}
+
+package() {
+msg "Packaging - $pkgname-$pkgver"
+ cd ${srcdir}/applications/${pkgname#*-} # use for libtool
+
+make -j1 DESTDIR="${pkgdir}" install
+}