summaryrefslogtreecommitdiffstats
path: root/debian/_buildscripts/local/README.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-09-14 23:42:25 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-09-14 23:42:25 +0900
commitfc2fae6cf24f7cea2374dcba2e73680305c32e53 (patch)
tree298deb3179e6cf09c3e6cb12791a0d5f9e97de29 /debian/_buildscripts/local/README.txt
parentfc4b7b4fed7e3677794695cba02725acbc50a50d (diff)
downloadtde-packaging-fc2fae6cf24f7cea2374dcba2e73680305c32e53.tar.gz
tde-packaging-fc2fae6cf24f7cea2374dcba2e73680305c32e53.zip
DEB build scripts: updated to use extra dependency repository on TGW.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_buildscripts/local/README.txt')
-rw-r--r--debian/_buildscripts/local/README.txt124
1 files changed, 59 insertions, 65 deletions
diff --git a/debian/_buildscripts/local/README.txt b/debian/_buildscripts/local/README.txt
index c5daf21fb..e36f5ceed 100644
--- a/debian/_buildscripts/local/README.txt
+++ b/debian/_buildscripts/local/README.txt
@@ -26,28 +26,31 @@ A) Environment preparation
2_build: folder used for build preparation and for local builds
3_repo : local repo for package installation (to be configured in /etc/apt/sources.list)
buildscripts: contains a local copy of the build scripts, which can be modified as required
- - in TDE_DIR/1_git:
+ - in TDE_DIR/1_git:
edeps : contains extra dependency modules necessary to build TDE (this folder is not necessary
- is pre-built extra dependencies are used - see point 9 for more info)
+ if pre-built extra dependencies are used - see point 9 for more info)
hooks : contains build hook scripts to execute ad-hoc code before and after the building process.
Mainly used to apply patches automatically during the building process
-
+
4) Clone TDE git repositories
- TDE main repo
cd "$TDE_DIR/1_git"
- git clone https://mirror.git.trinitydesktop.org/gitea/TDE/tde
+ git clone https://mirror.git.trinitydesktop.org/gitea/TDE/tde.git
+ git clone https://mirror.git.trinitydesktop.org/gitea/TDE/scripts.git tde/scripts
cd tde
- git submodule init -- scripts
- git submodule update -- scripts
./scripts/switch_all_submodules_to_head_and_clean anonymous
+ - If you are not using pre-built extra dependencies:
+ cd "$TDE_DIR/1_git"
+ git clone https://mirror.git.trinitydesktop.org/gitea/TDE/extra-dependencies.git edeps
+
5) Add your user to the sudo group (not required if you are root)
su -c "adduser <username> sudo"
Logout and login again to make sure the new settings are applied.
* Optionally, consider extending your sudo timeout interval to avoid having to type your password too often
(this could be quite painful especially during long builds, which would not be able to complete if unattended).
To do this, type "sudo visudo" and then add "Defaults timestamp_timeout=<new timeout>", where the value is in
- minutes. Use a value of -1 to set an infinite timeout.
+ minutes. Use a value of -1 to set an infinite timeout.
6) Copy the files from "TDE_DIR/1_git/tde/packaging/debian/_buildscripts/local/additional_files" folder
to the respectivily named folders.
@@ -56,7 +59,7 @@ A) Environment preparation
sudo pbuilder create
If you wish to build for a different distro or architecture, use the command:
sudo DISTRO_NAME=<target distro> ARCHITECTURE=<target architecture> pbuilder create
-
+
8) Setup the build scripts locally:
- copy build scripts from "TDE_DIR/1_git/tde/packaging/debian/_buildscripts/local" to "TDE_DIR/buildscripts"
and make sure all shell scripts are executable
@@ -67,54 +70,42 @@ A) Environment preparation
* TDE_DIR to the correct path.
* DISTRO, DISTRO_NAME and ARCHITECTURE to match the distro and architecture you want to build for if different
from your current setup. Otherwise the variables can be left empty and auto detection will be performed.
- * UPDATE_BRANCHES to the branches you want to keep updated from the main repositories.
+ * UPDATE_BRANCHES to the branches you want to keep updated from the main repositories.
* DEFAULT_REPO_BRANCH to the branch to check out at the end of the repositories update process.
-9) Some additional packages (referred to as extra dependencies) are required to build and install TDE in debian/ubuntu.
- These modules can be built locally, but the procedure is a bit cumbersome. Alternatively, Slavek Banko's
- pre-built binaries can be used.
-
- 9.1) Using pre-built extra dependencies (recommended option)
+9) Some additional packages (referred to as extra dependencies) are required to build and install TDE in debian/ubuntu.
+ These modules can be built locally or alternatively Slavek Banko's pre-built binaries can be used.
+
+ 9.1) Using pre-built extra dependencies
- open "_config.sh" and set the variable USE_PREBUILD_EXTRA_DEPS to "y" (this is the default initial setting)
- - add the following lines to the /etc/apt/sources.list file. This will setup Slavek's repositories in apt for
+ - add the following lines to the /etc/apt/sources.list file. This will setup Slavek's repositories in apt for
installing the extra dependency packages when TDE is installed.
- * For R14.1.x series (repository branch "master")
- # --- SLAVEK BANKO'S EXTRA DEPENDENCIES REPOSITORY ---
- # - temporarily disabled -
- # - http://mirror.ppa.trinitydesktop.org/trinity-testing/dists <YOUR DISTRO> deps
- deb http://mirror.ppa.trinitydesktop.org/trinity-sb <YOUR DISTRO> deps-r14
- * For R14.0.x series (repository branch "r14.0.x")
- # --- SLAVEK BANKO'S EXTRA DEPENDENCIES REPOSITORY ---
- deb http://mirror.ppa.trinitydesktop.org/trinity-sb <YOUR DISTRO> deps-r14
- For example:
- deb http://mirror.ppa.trinitydesktop.org/trinity-sb buster deps-r14
- - install package dirmngr if required
- - import TDE Archive Signing key into your apt keyring
- sudo apt-key adv --keyserver pool.sks-keyservers.net --recv-key C93AF1698685AD8B
-
- 9.2) Building extra dependencies locally
- - open "_config.sh" and set the variable USE_PREBUILD_EXTRA_DEPS to "n"
- - install the following packages: links2 and required dependencies.
- - using links2 (or another browser), download the source code for the extra dependency modules from
- Slavek's PPA (usually more recently updated):
- https://quickbuild.pearsoncomputing.net/~slavek-banko/+archive/deps-r14/+packages
- or from the official PPA:
- https://quickbuild.pearsoncomputing.net/~trinity/+archive/trinity-nightly-build-dependencies/+packages
- NOTES:
- * Once the page open in your browser, select your distro in the combobox near the "Filter" button and click
- the button to update. You should get a list of 10-15 modules, depending on the distro.
- * Click on one module at a time, it will expand (or open another page) and show a list of .deb and other files.
- * Save those files (exclude .deb files. Only .orig.tar.xz, .dsc, .debian.tar.xz are required) and store
- them to TDE_DIR/1_git/edeps/<MODULE NAME> folder (one folder per module).
+ * For R14.1.x series (repository branch "master")
+ # --- SLAVEK BANKO'S EXTRA DEPENDENCIES REPOSITORY ---
+ deb http://mirror.ppa.trinitydesktop.org/trinity-testing <YOUR DISTRO> deps
+ * For R14.0.x series (repository branch "r14.0.x")
+ # --- SLAVEK BANKO'S EXTRA DEPENDENCIES REPOSITORY ---
+ deb http://mirror.ppa.trinitydesktop.org/trinity-sb <YOUR DISTRO> deps-r14
+ For example:
+ deb http://mirror.ppa.trinitydesktop.org/trinity-sb buster deps-r14
+
+ - install package dirmngr if required
+ - import TDE Archive Signing key into your apt keyring
+ sudo apt-key adv --keyserver pool.sks-keyservers.net --recv-key C93AF1698685AD8B
+
+ 9.2) Building extra dependencies locally (recommended option)
+ - open "_config.sh" and set the variables USE_PREBUILD_EXTRA_DEPS to "n" and
+ CFG_EXTRA_DEPS_DIR to "edeps"
+ - build the extra dependency as any other normal module
10) Add the following lines to the /etc/apt/sources.list file. This will setup your local repo in apt.
- # --- LOCAL TDE REPOSITORY ---
- deb [trusted=yes] file:TDE_DIR/3_repo <YOUR DISTRO> main
- For example:
- deb [trusted=yes] file:/home/tde_src/3_repo buster main
+ # --- LOCAL TDE REPOSITORY ---
+ deb [trusted=yes] file:TDE_DIR/3_repo <YOUR DISTRO> main
+ For example:
+ deb [trusted=yes] file:/home/tde_src/3_repo buster main
+
-
----------------------
B) Notes about scripts
----------------------
@@ -145,7 +136,7 @@ When building sets of modules or the whole TDE, a global build summary is automa
update_git_repository.sh [options]
Options:
-i (Incremental) : in case the previous update was interrupted, continue from the last known updated module.
- (useful on slow/unstable internet connections). If the previous update had completed,
+ (useful on slow/unstable internet connections). If the previous update had completed,
this option is ignored.
-v (Verbose) : display and log more output. Useful for troubleshooting.
-ub "<branches>" (Update Branches) : allows to specify the branches to update. This override the variable
@@ -164,13 +155,16 @@ When building sets of modules or the whole TDE, a global build summary is automa
tdebase
applications/abakus
dependencies/libr
- edeps/imlib
+ edeps/debian/imlib
2) by providing only the module name and let the script look up for a unique match among the known modules.
Examples:
tdebase
abakus
libr
imlib
+ 3) for extra dependencies only, by providing the repository folder and the module name without the "debian"
+ subfolder
+ edeps/imlib
Usage:
build_module.sh [options] module_name
Options:
@@ -183,17 +177,17 @@ When building sets of modules or the whole TDE, a global build summary is automa
doing local changes/development. The module can then be built from the modified local folder
-d (Debug) : enable debug symbols if possible (debian/rules file must contain "RelWithDebInfo" for this to work)
-ip (Internal Pbuilder): build using internal pbuilder mode (experimental)
-
+
- <dd>_<set_name>.sh
A number of scripts used to build sets of modules. Each script builds an individual set.
- Modules are built from the git sources and the build result is automatically appended to
+ Modules are built from the git sources and the build result is automatically appended to
TDE_DIR/0_logs/build_result.log.
Usage:
<dd>_<set_name>.sh [options] set_name
Options:
-s N: if specified, skip first N modules from the set of modules
- The sets are logically grouped as "base system", "applications" and "others"
+ The sets are logically grouped as "base system", "applications" and "others"
00_extradeps.sh : extra dependencies modules
01_base_01.sh - 03_base_03.sh : TDE base system
04_application_01.sh - 09_application_06.sh : application modules
@@ -206,20 +200,20 @@ When building sets of modules or the whole TDE, a global build summary is automa
Script used to build the complete TDE at once. Calls the dd_setname.sh set scripts in order.
Usage:
build_TDE.sh
-
+
- create_repo.sh
- Creates a local repository from the .deb files currently stored in TDE_DIR/2_build/debs.
+ Creates a local repository from the .deb files currently stored in TDE_DIR/2_build/debs.
Usage:
[sudo] create_repo.sh [options]
Options:
-b (Backup) : create a backup of the existing repository in TDE_DIR/CFG_REPO_DIR.backup
-
+
3) * Building hooks *
Hooks are available to execute ad-hoc code before and after the build process. For example this is very useful to automatically apply patches.
-There are two type of hooks:
+There are two type of hooks:
- pre_build : applied before switching the module to quilt format and build
-- post_build: applied after the build (dpkg-buildpackage or pbuilder) has terminated
+- post_build: applied after the build (dpkg-buildpackage or pbuilder) has terminated
To use a hook, create an executable script (pre_build.sh and/or post_build.sh) in the TDE_DIR/1_git/hooks/<MODULE NAME> folder. The scripts are executed in the build_module.sh environment, so have access to all the variables defined in that file. See the files in the "hook examples" folder for real usage samples.
@@ -235,7 +229,7 @@ C) How to use the scripts
the process when building several modules in sequence.
5) Build modules as per your needs. You don't need to use "sudo" directly since the scripts will do that automatically if
required. Just type your sudo password when prompted to do so.
-6) Create a local repository from the packages you have just built, to be used as installation repository.
+6) Create a local repository from the packages you have just built, to be used as installation repository.
[sudo] ./create_repo.sh
7) Install TDE as you usually do. For example as follow:
- sudo apt-get update
@@ -243,15 +237,15 @@ C) How to use the scripts
or
sudo aptitude install tde-trinity (for a standard TDE environment)
-
-
+
+
Examples of real usage:
1) build a single module
- ./build_module.sh -g -sl "dependencies/libr" -> build libr package. This is a good test to check
whether everything is working fine
- ./build_module.sh -g "tdelibs" -> build "tdelibs" from git sources in a clean chroot environment
- - ./build_module.sh -g -l -sl "applications/amarok" -> build "amarok" locally from git sources and
+ - ./build_module.sh -g -l -sl "applications/amarok" -> build "amarok" locally from git sources and
display building logs during building
- ./build_module.sh -sh -lr "tdebase" -> build "tdebase" from the local sources (in TDE_DIR/2_build/build/tdebase)
in a clean chroot environment and launch a shell in case of building failure.
@@ -259,13 +253,13 @@ Examples of real usage:
- ./build_module.sh -g -po "tdelibs" -> prepare "tdelibs" for building from git sources. Source code will be available
in TDE_DIR/2_build/build/tdelibs. After you have made changes to the source and
want to build the modified package, run './build_module.sh "tdelibs"'
-
+
2) build a single set
(optional) delete the TDE_DIR/0_logs/build_result.log file
- ./01_base_01.sh -> build this set.
+ ./01_base_01.sh -> build this set.
./03_base_03.sh -s 3 -> build this set but skip the first 3 modules of the set.
3) build all TDE
./99_build_TDE.sh -> build all TDE
-4) [sudo] ./create_repo.sh -> build or update your local TDE repository \ No newline at end of file
+4) [sudo] ./create_repo.sh -> build or update your local TDE repository